现在的位置: 首页 > 综合 > 正文

hdu4952Number Transformation (找规律)

2018年02月22日 ⁄ 综合 ⁄ 共 865字 ⁄ 字号 评论关闭

Number Transformation

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 76 Accepted Submission(s): 28

Problem Description
Teacher Mai has an integer x.

He does the following operations k times. In the i-th operation, x becomes the least integer no less than x, which is the multiple of i.

He wants to know what is the number x now.

Input
There are multiple test cases, terminated by a line "0 0".

For each test case, the only one line contains two integers x,k(1<=x<=10^10, 1<=k<=10^10).

Output
For each test case, output one line "Case #k: x", where k is the case number counting from 1.

Sample Input
2520 10 2520 20 0 0

Sample Output
Case #1: 2520 Case #2: 2600

Source
#include<stdio.h>
int main()
{
    __int64 x,k,i,j,t=0;
    while(scanf("%I64d%I64d",&x,&k)>0&&(x||k))
    {
        i=2;
        while(i<=k)
        {
            if(x%i!=0)
            {
                j=x/i+1; if(j<=i){x=j*k;break;}
                x=i*j;
            }
            else
            {
                j=x/i; if(j<=i){x=j*k;break;}
            }
            i++;
        }
        printf("Case #%I64d: %I64d\n",++t,x);
    }
}

抱歉!评论已关闭.