现在的位置: 首页 > 综合 > 正文

hdu2289Cup(神坑题,精度+二分,以半径二分不能过,以高度为二分就过了)

2018年02月22日 ⁄ 综合 ⁄ 共 1120字 ⁄ 字号 评论关闭
Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height?

The radius of the cup's top and bottom circle is known, the cup's height is also known.

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.

Sample Input
1 100 100 100 3141562

Sample Output
99.999024
#include<stdio.h>
#include<math.h>
#define e 0.0000001
#define  PI acos(-1.0)
double V,r,H,R,h;
double cc(double x,double th)
{
    return PI*th*(x*x+x*r+r*r)/3.0;
}
void ccc(double ans)
{
    double m,l,ri;
    l=0;ri=100.0;
    while(l+e<ri)
    {
        m=(l+ri)/2.0;
        if(cc(r+m*(R-r)/H,m)>ans)ri=m;
        else l=m;
    }
    h=m;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf%lf%lf%lf",&r,&R,&H,&V);
        ccc(V);
        printf("%.6lf\n",h);
    }
}

抱歉!评论已关闭.