现在的位置: 首页 > 综合 > 正文

HDU4939Stupid Tower Defense (有思想的dp)

2018年02月22日 ⁄ 综合 ⁄ 共 2243字 ⁄ 字号 评论关闭

Stupid Tower Defense

Time Limit: 12000/6000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1557 Accepted Submission(s): 445

Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.

The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.

The red tower damage on the enemy x points per second when he passes through the tower.

The green tower damage on the enemy y points per second after he passes through the tower.

The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)

Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.

FSF now wants to know the maximum damage the enemy can get.

Input
There are multiply test cases.

The first line contains an integer T (T<=100), indicates the number of cases.

Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)

Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.

Sample Input
1 2 4 3 2 1

Sample Output
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.

Author
UESTC

Source
分析:红塔只对过塔的人功击,绿塔对之后的所有塔的走过人功击,篮塔只会廷长过塔时间,假设有n个塔,有e个绿塔,j个篮塔,k个红塔,n=e+j+k;红塔不管放哪里都只对当前过塔人功击,要想总功击最大那么所有的红塔必须放在最后,那么现在只要在枚举出e和j的个数,k=n-e-j; k个红塔都排在最后,设dp[i][j]表示前i个塔中有j个篮塔的最大功击值。
#include<stdio.h>
#include<string.h>
#define ll __int64
ll dp[1505][1505];
int main()
{
    ll T,n,x,y,z,t,ans,c=0,aa;
    for(int i=0;i<=1500;i++)
    dp[0][i]=0;
    scanf("%I64d",&T);
    while(T--)
    {
        scanf("%I64d%I64d%I64d%I64d%I64d",&n,&x,&y,&z,&t);
        ans=n*t*x;
        for(ll i=1;i<=n;i++)
        for(ll j=0;j<=i;j++)
        {
            dp[i][j]=dp[i-1][j]+(i-1-j)*(j*z+t)*y;//第i个塔是绿塔
            if(j>0)
            {
                 aa=dp[i-1][j-1]+(i-j)*((j-1)*z+t)*y;//第i个塔是篮塔
                if(dp[i][j]<aa)  dp[i][j]=aa;
            }
            aa=dp[i][j]+((i-j)*y+x)*(j*z+t)*(n-i);//加上红塔的功击值(来自前面的塔和自身)
            if(aa>ans)  ans=aa;
        }

        printf("Case #%I64d: %I64d\n",++c,ans);
    }
}

抱歉!评论已关闭.