现在的位置: 首页 > 综合 > 正文

hdu1208Pascal’s Travels (DFS+记忆化搜索(DP))

2018年02月22日 ⁄ 综合 ⁄ 共 1863字 ⁄ 字号 评论关闭
文章目录

Problem Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how
large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents
any further progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.



Figure 1




Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board.
This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board.

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output

3
0
7

Hint

Hint
Brute force methods examining every path will likely exceed the allotted time limit.

64-bit integer values are available as "__int64" values using the Visual C/C++ or 
题目意思是:只能往右走或往下走。
#include<stdio.h>
char map[38][38];
int n;
__int64 dp[38][38];
__int64 DFS(int x,int y)
{
    int e,tx,ty;
    if(y==n&&x==n)
        return 1;
    if(map[y][x]=='0'||dp[y][x]>0)
        return dp[y][x];

    for(e=0;e<2;e++)
    {
        if(e==0)
        {
            tx=x+map[y][x]-'0';ty=y;
        }
        else
        {
             tx=x;ty=y+map[y][x]-'0';
        }
        if(tx<=n&&ty<=n)
        dp[y][x]+=DFS(tx,ty);
    }
    return dp[y][x];
}
int main()
{
    int i,j;
    __int64 step;
    while(scanf("%d",&n)>0&&n!=-1)
    {
        getchar();
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                scanf("%c",&map[i][j]);
                dp[i][j]=0;
            }
            getchar();
        }
        step=DFS(1,1);
        printf("%I64d\n",step);
    }
}

抱歉!评论已关闭.