现在的位置: 首页 > 综合 > 正文

poj2182Lost Cows(线段树,单点更新,输入的是每个点的逆序数,求出原序列)

2018年02月22日 ⁄ 综合 ⁄ 共 1706字 ⁄ 字号 评论关闭

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did
not line up in the required ascending numerical order of their brands. 

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow
in line that do, in fact, have smaller brands than that cow. 

Given this data, tell FJ the exact ordering of the cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows
whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on. 

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1
可以把这个输入的看作是要放到第几个位置,把每个位置的未知数按从小到大排列。那么最后一个位置开始入。
#include<stdio.h>
#define N 10000
int tree[4*N],num[N+5];
void builde(int l,int r,int k)
{
    int m=(l+r)/2;
    tree[k]=r-l+1;
    if(l==r) return ;
    builde(l,m,k*2); builde(m+1,r,2*k+1);
}
void updata(int l,int r,int k,int p,int i)
{
    int m=(l+r)/2;
    tree[k]--;
    if(l==r){
        num[i]=l; return ;
    }
    if(tree[k*2]>=p) updata(l,m,k*2,p,i);
    else updata(m+1,r,k*2+1,p-tree[k*2],i);
}
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        num[0]=0;
        for(int i=1;i<n;i++)
        scanf("%d",&num[i]);
        builde(1,n,1);
        for(int i=n-1;i>=0;i--)
        updata(1,n,1,num[i]+1,i);
        for(int i=0;i<n;i++)
        printf("%d\n",num[i]);
    }
}

抱歉!评论已关闭.