现在的位置: 首页 > 综合 > 正文

poj2828Buy Tickets(线段树,每次插入后把余下的看作是一个新的集合)

2018年02月22日 ⁄ 综合 ⁄ 共 2710字 ⁄ 字号 评论关闭

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped
the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in
the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue
    was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


题 目意思:有n个数,进行n次操作,每次操作有两个数pos, ans。pos的意思是把ans放到第pos 位置的后面,pos后面的数就往后推一位。最后输出每个位置的ans。

思路:根据题 目可知,最后插入的位置的数才是最终不变的数,所以可以从最后的输入作第1个放入,依此类推,倒插入。在插入时也有一定的技术,首先创建一棵空线段树时,每个节点记录当前范围内有多少个空位置。在插入时,要注意,一个数放入之后那么这个位置就不用管了,那么树中所有的空位置就是余下的数所对应的位置,也就是把余下的数又可以看作是一个新的集合。那么每次插入都是当前集合的第1次放。

#include<stdio.h>
#include<iostream>
#include<map>
using namespace std;
#define N 300005
struct nod
{
    int p,num;
}node[N];
int tree[4*N],num[N];
void biulde(int l,int r,int k)
{
    int m=(l+r)/2;
    tree[k]=r-l+1;
    if(l==r) return ;
    biulde(l,m,k*2); biulde(m+1,r,k*2+1);
}
void updata(int l,int r,int k,int posit,int ans)
{
    int m=(l+r)/2;
    tree[k]--;
    if(l==r)
    {
        num[l]=ans;  return ;
    }
    if(posit<=tree[k*2]) updata(l,m,k*2,posit,ans);
    else
    {
        posit-=tree[k*2];
        updata(m+1,r,k*2+1,posit,ans);
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)>0)
    {
        biulde(1,n,1);
        for(int i=1;i<=n;i++)
        scanf("%d%d",&node[i].p,&node[i].num);
        for(int i=n;i>0;i--)
            updata(1,n,1,node[i].p+1,node[i].num);
        printf("%d",num[1]);
        for(int i=2;i<=n;i++)
        printf(" %d",num[i]);
        printf("\n");
    }
}

抱歉!评论已关闭.