现在的位置: 首页 > 综合 > 正文

poj2001Shortest Prefixes(字典树)

2018年02月22日 ⁄ 综合 ⁄ 共 2125字 ⁄ 字号 评论关闭

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string
is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that
uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list
that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
#include<stdio.h>
#include<string.h>
typedef struct nn
{
    int flag;
    struct nn *next[26];
}node;
node *builde()
{
    node *p=new node;
    p->flag=0;
    for(int i=0;i<26;i++)
    p->next[i]=NULL;
    return p;
}
node *root;
void insert(char str[])
{
    node *p=root;
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']==NULL)
        p->next[str[i]-'a']=builde();
        p=p->next[str[i]-'a'];
        p->flag++;
    }
}
void find(char str[])
{
    node *p=root;
    printf("%s ",str);
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']==NULL)
            break ;
        printf("%c",str[i]);
        p=p->next[str[i]-'a'];
        if(p->flag==1)
        break ;
    }
    printf("\n");
}
int main()
{
    char str[2005][25];
    int n=0;
    root=builde();
    while(scanf("%s",str[n])>0)
    {
        insert(str[n]); n++;
    }
    for(int i=0;i<n;i++)
    find(str[i]);
}

抱歉!评论已关闭.