现在的位置: 首页 > 综合 > 正文

hdu1004Let the Balloon Rise (简箪题用字典树做)

2018年02月22日 ⁄ 综合 ⁄ 共 1396字 ⁄ 字号 评论关闭
Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5 green red blue red red 3 pink orange pink 0

Sample Output
red pink
#include<stdio.h>
#include<iostream>
#include<malloc.h>
#include<string.h>
using namespace std;
typedef struct nnn
{
    int num;//单词出现的次数
    int flag;//为1表示前缀存在这一个单词
    struct nnn *next[26];
}node;
int MAX;
char chs[50];
node *root;
node *builde()
{
    node *p=(node*)malloc(sizeof(node));
    p->num=0; p->flag=0;
        for(int i=0;i<26;i++)
        p->next[i]=NULL;
    return p;
}
void insert(char str[])
{
    node *p=root;
    for(int i=0;str[i]!='\0';i++)
    {
        if(p->next[str[i]-'a']==NULL)
        p->next[str[i]-'a']=builde();
        p=p->next[str[i]-'a'];
    }
    p->flag=1; p->num++;
    if((p->num)>MAX)
    {
        MAX=p->num; strcpy(chs,str);
    }
}
int main()
{
    int n;
    char str[50];
    while(scanf("%d",&n)>0&&n!=0)
    {
        MAX=0;
        root=builde();
        while(n--)
        {
            scanf("%s",str);
            insert(str);
        }
        printf("%s\n",chs);
    }
}

抱歉!评论已关闭.