现在的位置: 首页 > 综合 > 正文

hdu1856 More is better(并查集,运用了压缩路径)

2018年02月22日 ⁄ 综合 ⁄ 共 1625字 ⁄ 字号 评论关闭
Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,
the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends.
(A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8

Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
注意:n为0时,输出1;
#include<stdio.h>
struct node{
    int x;
    int s;
}fath[10000005];
int sum;
void set_first(int n)//
{
    int i;
    for(i=1;i<=n;i++)
    {
        fath[i].x=i;
        fath[i].s=1;
    }
}
int find_fath(int X)
{
    if(X!=fath[X].x)
    fath[X].x=find_fath(fath[X].x);
    return fath[X].x;
}
void set_fath(int a,int b)
{
    int na,nb;
    na=find_fath(a);
    nb=find_fath(b);

    if(na!=nb)
    fath[na].s+=fath[nb].s;
    fath[nb].x=na;
    if(fath[na].s>sum)
    sum=fath[na].s;    
}
int main()
{
    int n,a,b,max=0;
    set_first(10000000);
    while(scanf("%d",&n)>0)
    {
        sum=1;
        set_first(max);
        max=0;
        while(n--)
        {
            scanf("%d%d",&a,&b);
            set_fath(a,b);
            max=(max<a)?a:max;
            max=(max<b)?b:max;
        }
        printf("%d\n",sum);
    }
}

抱歉!评论已关闭.