现在的位置: 首页 > 综合 > 正文

hdu1217Arbitrage (spfa算法)

2018年02月22日 ⁄ 综合 ⁄ 共 2288字 ⁄ 字号 评论关闭
Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys
10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within
a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name
cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0

Sample Output
Case 1: Yes Case 2: No
#include<cstdlib>
#include<stdio.h>
#include<string>
#include<iostream>
#include<queue>
#include<map>
using namespace std;
double mp[35][35],node[35];
int n;
int spfa(int sta)
{
    int inq[35]={0},t;
    queue<int>q;
    q.push(sta); inq[sta]=1;
    node[sta]=1;
    while(!q.empty())
    {
        t=q.front(); q.pop();
        inq[t]=0;
        for(int i=1;i<=n;i++)
        if(node[i]<mp[t][i]*node[t])
        {
            node[i]=mp[t][i]*node[t];
            if(node[sta]>1) return 1;
            if(!inq[i])
            q.push(i);
            inq[i]=1;
        }
    }
    return 0;
}
int main()
{
    int m,a,b,cas=0;
    map<string,int>nam;
    double p;
    char ch[30],ch1[30];
    while(scanf("%d",&n)>0&&n)
    {
        for(int i=1;i<=n;i++)
        {
            node[i]=0;
            for(int j=1;j<=n;j++)
            mp[i][j]=0;
        }
        nam.clear();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",ch);
            nam[ch]=i;
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s %lf %s",ch,&p,ch1);
            a=nam[ch]; b=nam[ch1];
            if(mp[a][b]<p)
            mp[a][b]=p;
        }
        printf("Case %d: %s\n",++cas,spfa(1)?"Yes":"No");
    }
}

抱歉!评论已关闭.