现在的位置: 首页 > 综合 > 正文

hdu1690 Bus System (dijkstra)

2018年02月22日 ⁄ 综合 ⁄ 共 3144字 ⁄ 字号 评论关闭
Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.

Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start
point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.

Sample Input
2 1 2 3 4 1 3 5 7 4 2 1 2 3 4 1 4 4 1 1 2 3 4 1 3 5 7 4 1 1 2 3 10 1 4

Sample Output
Case 1: The minimum cost between station 1 and station 4 is 3. The minimum cost between station 4 and station 1 is 3. Case 2: Station 1 and station 4 are not attainable.
这题一定要注意把INF设的很大,不然会WA
#include<stdio.h>
const long long INF = 99999999999LL;
__int64 map[105][105],node[105];
int n,s[105];
__int64 abs(__int64 a)
{
    return a>0?a:-a;
}
void set_1()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        map[i][j]=INF;
    }
}
void set_2()
{
    for(int i=1;i<=n;i++)
    {
        s[i]=0; node[i]=INF;
    }
}
__int64 dijkstra(int stra,int end)
{
    int tstra=stra;
    __int64 min;
    s[stra]=1; node[stra]=0;
    for(int k=2;k<=n;k++)
    {
        min=INF;
        for(int i=1;i<=n;i++)
        if(s[i]==0)
        {
            if(node[i]>map[tstra][i]+node[tstra])
            node[i]=map[tstra][i]+node[tstra];
            if(min>node[i])
            {
                min=node[i]; stra=i;
            }
        }
        s[stra]=1; tstra=stra;
        if(s[end])
        break;
    }
    if(node[end]==INF)
    return -1;
    return node[end];
}
int main()
{
    int t,m,k=1,cas[505][2];
    __int64 l[5],c[5],posit[105],dist;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=1;i<=4;i++)
        scanf("%I64d",&l[i]);
        for(int i=1;i<=4;i++)
        scanf("%I64d",&c[i]);
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        scanf("%I64d",&posit[i]);

        set_1();
        for(int i=1;i<=n;i++)
        for(int j=i+1;j<=n;j++)
        {
            dist=abs(posit[i]-posit[j]);
            if(dist<=l[1])
            map[i][j]=map[j][i]=c[1];
            else if(dist<=l[2])
            map[i][j]=map[j][i]=c[2];
            else if(dist<=l[3])
            map[i][j]=map[j][i]=c[3];
            else if(dist<=l[4])
            map[i][j]=map[j][i]=c[4];
        }

        printf("Case %d:\n",k++);
        __int64 cost;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&cas[i][0],&cas[i][1]);
            
            set_2();
            cost=dijkstra(cas[i][0],cas[i][1]);
            if(cost!=-1)
            printf("The minimum cost between station %d and station %d is %I64d.\n",cas[i][0],cas[i][1],cost);
            else
            printf("Station %d and station %d are not attainable.\n",cas[i][0],cas[i][1]);
        }
    }
}

抱歉!评论已关闭.