现在的位置: 首页 > 综合 > 正文

hdu1546Idiomatic Phrases Game (dijkstra的变形)

2018年02月22日 ⁄ 综合 ⁄ 共 2247字 ⁄ 字号 评论关闭
Problem Description
Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with
the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary
has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.

Input
The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will
take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms
in the game. The input ends up with a case that N = 0. Do not process this case.

Output
One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.

Sample Input
5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0

Sample Output
17 -1
注意把初始化的值定大点,我就是在这里错了几次。
#include<stdio.h>
#include<string.h>
typedef struct nn
{
    int p,len;
    char ch[1000];
}idiom;
idiom id[1005];
int map[1005][1005],s[1005],node[1005],n,INF=999999999;
void set()//初始化
{
    for(int i=1;i<=n;i++)
    {
        s[i]=0; node[i]=INF;
        for(int j=1;j<=n;j++)
        map[i][j]=INF;
    }
}
int dijkstra(int m)
{
    int min,tm=m;
    if(n==1)//当只有一个时反回-1
    return -1;
    s[m]=1; node[m]=0;
    for(int k=2;k<=n;k++)
    {
        min=INF;
        for(int i=1;i<=n;i++)
        if(s[i]==0)
        {
            if(node[i]>map[tm][i]+node[tm])//更新
            node[i]=map[tm][i]+node[tm];
            if(min>node[i])//找最小权的点
            {
                min=node[i]; m=i;
            }
        }
        s[m]=1; tm=m;//把最小的点放到s集合中
        if(m==n)break;//如果点n己经加入到s集合中则可以跳出,因为加入的点不会再更新
    }
    if(node[n]==INF)
    return -1;
    return node[n];
}
int main()
{
    int e;
    while(scanf("%d",&n)>0&&n)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d %s",&id[i].p,id[i].ch);
            id[i].len=strlen(id[i].ch);
        }
        set();
        for(int i=1;i<=n;i++)//变成地图
        for(int j=1;j<=n;j++)
        if(i!=j)
        {
            for(e=1;e<=4;e++)
            if(id[i].ch[id[i].len-e]!=id[j].ch[4-e])
            break;
            if(e<=4)continue;

            map[i][j]=id[i].p;//单向
        }
        printf("%d\n",dijkstra(1));
    }
}

抱歉!评论已关闭.