现在的位置: 首页 > 综合 > 正文

poj2923Relocation(01背包+状态压缩)

2018年02月22日 ⁄ 综合 ⁄ 共 2896字 ⁄ 字号 评论关闭

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the
furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If
a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1
≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤
100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move
all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

Source

TUD Programming Contest 2006, Darmstadt, Germany
解题:首先将载重最重的车一次能载的情况列出来,第几个物能载入车,就用状态压缩在相应的位置置为1,否则为0。同理载重小的车列举出来。然后两个用或运算合起来,表示一次两车运的物体。(注意:要把载最重的车能载的情况也看作是一次合)
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define inf 0xffffff
int w[12],n,yasuo[2][1<<10+5],k[2],dp[1<<10+5];
void dfs(int i,int W,int j,int ans,int setW)
{
    if(j+1==n)
    {
        if(setW<=W&&setW)
            yasuo[i][k[i]++]=ans;
        return ;
    }
    if(setW+w[j+1]<=W)
    dfs(i,W,j+1,ans|(1<<(j+1)),setW+w[j+1]);
    dfs(i,W,j+1,ans,setW);
}
void zeroonepack(int use)
{
    for(int u=(1<<n)-1;u>=0;u--)
    if(dp[u|use]>dp[u]+1)
    dp[u|use]=dp[u]+1;
}
int USE[1080000],uk;
int main()
{
    int AW,BW,c=0,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&AW,&BW);
        int tm;
        if(AW<BW)
        {
            tm=AW; AW=BW;BW=tm;
        }
        for(int j=0;j<n;j++)
            scanf("%d",&w[j]);
            k[0]=k[1]=0; uk=0;
        for(int i=1;i<(1<<n);i++)
            dp[i]=inf;
            dp[0]=0;

        dfs(0,AW,-1,0,0);//举出能载最重货物的情况
        dfs(1,BW,-1,0,0);
       for(int i=0;i<k[0];i++)
        {
            USE[uk++]=yasuo[0][i];//一定要加入最大值AW的情况,不然当BW小于所有的重物或最后只需辆车运时,没有合的情况
           for(int j=0;j<k[1];j++)
                USE[uk++]=(yasuo[0][i]|yasuo[1][j]);
        }
        sort(USE,USE+uk);
       for(int i=0;i<uk;i++)
       if(i==0||USE[i-1]!=USE[i])
           zeroonepack(USE[i]);

        int M=(1<<n)-1;
       printf("Scenario #%d:\n%d\n\n",++c,dp[M]);
    }
}

抱歉!评论已关闭.