现在的位置: 首页 > 综合 > 正文

hdu1963Investment (完全背包)

2018年02月22日 ⁄ 综合 ⁄ 共 2826字 ⁄ 字号 评论关闭
Problem Description
John never knew he had a grand-uncle, until he received the notary’s letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor.

John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him.

This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized
that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated.

Assume the following bonds are available:
Value Annual interest
4000 400
3000 250

With a capital of $10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes
sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000,
giving a yearly interest of $1 200.

Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input
The first line contains a single positive integer N which is the number of test cases. The test cases follow.

The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40).

The following line contains a single number: the number d (1 <= d <= 10) of available bonds.

The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond.
The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output
For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input
1 10000 4
2 4000 400 3000 250

Sample Output
14050
题意:有很多钱存入银行,存n年,银行不有同的债券,达到该劵给定的钱数,才可购买,得到相应的利息。每一年的年末总钱数都是 本金=本金 + 利息。问存n年后总钱数为多少。
解题:这一道完全背包。但要注意的是,n年后本金有可以很大,数组是无法装。那么注意题中的我所标注红色部分,意思为每个债券的钱数是1000的陪数。本金少于1000,肯定不能买债券,那么可以债券钱数除以1000,同时每一年的背包大小为 本金/1000 。
#include<stdio.h>
#define N 1000005
struct nnn
{
    int use,w;
}bond[15];
int dp[N],V;
void complexepack(int use,int w)
{
    for(int v=use;v<=V;v++)
    if(dp[v]<dp[v-use]+w)
    dp[v]=dp[v-use]+w;
}
int main()
{
    int t,y,typ,Max;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&Max,&y);
        scanf("%d",&typ);
        for(int i=0;i<typ;i++)
        {
            scanf("%d%d",&bond[i].use,&bond[i].w);
            bond[i].use/=1000;
        }
        while(y--)
        {
            V=Max/1000;
            for(int i=0;i<=V;i++)
                dp[i]=0;
            for(int i=0;i<typ;i++)
            complexepack(bond[i].use,bond[i].w);
            Max=Max+dp[V];
        }
    printf("%d\n",Max);
    }
}

抱歉!评论已关闭.