现在的位置: 首页 > 综合 > 正文

hdu3074Multiply game(线段树 点更新,求段的积)

2018年02月22日 ⁄ 综合 ⁄ 共 2069字 ⁄ 字号 评论关闭
Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found
it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

Input
The first line is the number of case T (T<=10).
For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,

Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)

1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are
no larger than 1 million
.

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after
mod 1000000007.

Sample Input
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5

Sample Output
240 420
#include<stdio.h>
#define N 50000
int L,R;
__int64 A,tree[N*4];
void build(int l,int r,int k)
{
    int m=(l+r)/2;
    tree[k]=1;
    if(l==r) return ;
    build(l,m,k*2);
    build(m+1,r,k*2+1);
}
void set_tree(int l,int r,int k)
{
    int m=(l+r)/2;
    if(l==L&&L==r)
    {
        tree[k]=(__int64)R; return;
    }
    if(L<=m) set_tree(l,m,k*2);
    if(L>m) set_tree(m+1,r,k*2+1);
    tree[k]=(tree[k*2]*tree[k*2+1])%1000000007;
}
void find(int l,int r,int k)
{
    int m=(l+r)/2;
    if(L<=l&&r<=R)
    {
        A=(A*tree[k])%1000000007;return ;
    }
    if(R<=m) find(l,m,k*2);
    else if(L>m) find(m+1,r,k*2+1);
    else
    {
        find(l,m,k*2); find(m+1,r,k*2+1);
    }
}
int main()
{
    int t,m,n,x;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        build(1,n,1);
        for(int i=1;i<=n;i++)
        {
            L=i;scanf("%d",&R); set_tree(1,n,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d%d%d",&x,&L,&R);
            if(x&&n) set_tree(1,n,1);
            else if(n){
                A=1; find(1,n,1);
                printf("%I64d\n",A);
            }
            else if(!x)printf("0\n");
        }
    }
}

抱歉!评论已关闭.