现在的位置: 首页 > 综合 > 正文

zoj2297Survival (状态压缩DP)

2018年02月22日 ⁄ 综合 ⁄ 共 2325字 ⁄ 字号 评论关闭

Survival


Time Limit: 5 Seconds
Memory Limit:
32768 KB


The King of Fighter 97 (KOF97) is an electronic game of wrestling type. Once it was fashionable among youths. The game is amused. However, playing by oneself is not as excited as with friends. Getting bored? Maybe you can alter to the survival mode.

In the survival mode, you play as usual, but under quite unfair conditions: you must use your only character to beat all the other characters and Orichi as well (who is the BOSS)!!! How can you do that? We know that usually we will consume some HP of the
character to beat one opponent. Although the character will recover some HP after beating one opponent, the amount of HP recovered is affected by the time you used, so it��s possible that the character lose some HP after one round. What��s worse, if the HP
of your character is not enough for you to beat your opponent, you lose!

Given the HP of your character you need to consume and the HP your character will recover if you win for every opponent, you are to determine whether you can clear the game.

NOTE:
1. The initial HP of your character is 100.
2. You can challenge your opponents in any order except that Orichi is always the last one.
3. If your HP falls BELOW zero after any fights (before recovery), you will get your mission failed. 4. Your HP should never exceed 100.

Input

There are multiple test cases, which are separated by a blank line. The first line of each test case is a single integer N (1 <= N <= 20), gives the number of opponents you need to beat. The following N �C 1 lines each contain two integers C and R (0 <= C,
R <= 100), where C for the HP you need to consume to beat the opponent and R for the HP recovered after you beat the opponent. The last line contains only one integer P (0 <= P <= 100), describing the HP you need to consume to beat Orichi.

Output

For each test case, generate one line of output: if you can clear the game, print "clear!!!" otherwise print "try again" (both without quotations).

Sample Input

3
50 50
40 40
70

Sample Output

clear!!!

题意:有n个Boss,其中有n-1个小boss必须先全部打完才能打第n个大BOSS,打一个小boss要耗体能usei,打完后恢愎一部分vali,一开始体能为100,在打的过程中也最多为100,问能打完全部的BOSS? 能 输出clear!!! 否则输出try again.

解法:用DP[i]表示打完i状态剩余的最大体能。

#include<stdio.h>
#include<string.h>
int n,use[25],val[25],HP[1100000];
int Max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    while(scanf("%d",&n)>0)
    {
        for(int i=0;i<n-1;i++)
        scanf("%d%d",&use[i],&val[i]);
        scanf("%d",&use[n-1]);
        memset(HP,-1,sizeof(HP));
        HP[0]=100;
        for(int i=1;i<(1<<(n-1));i++)
        {
            HP[i]=-9999;
            for(int j=0;(1<<j)<=i;j++)//在i状态中是最后一个打
                if(i&(1<<j)&&HP[i-(1<<j)]>=use[j])
                {
                    int m=HP[i-(1<<j)]-use[j]+val[j];
                    if(m>100)m=100;
                    if(m>HP[i])HP[i]=m;
                }
        }

        if(HP[(1<<(n-1))-1]>=use[n-1])
            printf("clear!!!\n");
        else printf("try again\n");
    }
}

抱歉!评论已关闭.