现在的位置: 首页 > 综合 > 正文

hdu 4035 Maze(比较经典的树形期望DP)

2018年03月18日 ⁄ 综合 ⁄ 共 3175字 ⁄ 字号 评论关闭

Maze

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 1677    Accepted Submission(s): 638
Special Judge

Problem Description
When wake up, lxhgww find himself in a huge maze.

The maze consisted by N rooms and tunnels connecting these rooms. Each pair of rooms is connected by one and only one path. Initially, lxhgww is in room 1. Each room has a dangerous trap. When lxhgww step into a room, he has a possibility to be killed and restart
from room 1. Every room also has a hidden exit. Each time lxhgww comes to a room, he has chance to find the exit and escape from this maze.

Unfortunately, lxhgww has no idea about the structure of the whole maze. Therefore, he just chooses a tunnel randomly each time. When he is in a room, he has the same possibility to choose any tunnel connecting that room (including the tunnel he used to come
to that room).
What is the expect number of tunnels he go through before he find the exit?

 

Input
First line is an integer T (T ≤ 30), the number of test cases.

At the beginning of each case is an integer N (2 ≤ N ≤ 10000), indicates the number of rooms in this case.

Then N-1 pairs of integers X, Y (1 ≤ X, Y ≤ N, X ≠ Y) are given, indicate there is a tunnel between room X and room Y.

Finally, N pairs of integers Ki and Ei (0 ≤ Ki, Ei ≤ 100, Ki + Ei ≤ 100, K1 = E1 = 0) are given, indicate the percent of the possibility of been killed and exit in the ith room.

 

Output
For each test case, output one line “Case k: ”. k is the case id, then the expect number of tunnels lxhgww go through before he exit. The answer with relative error less than 0.0001 will get accepted. If it is not possible to escape
from the maze, output “impossible”.
 

Sample Input
3 3 1 2 1 3 0 0 100 0 0 100 3 1 2 2 3 0 0 100 0 0 100 6 1 2 2 3 1 4 4 5 4 6 0 0 20 30 40 30 50 50 70 10 20 60
 

Sample Output
Case 1: 2.000000 Case 2: impossible Case 3: 2.895522
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  4037 4036 4033 4038 4039 
 题意:
一些房间构成一个树形的迷宫。你开始在以后房间。你每个房间你有ki的概率被杀掉。ei的概率逃出迷宫。如果既没被杀掉又没逃出去。你就会随机选一条能走的边走,最后问你走出这个迷宫需要走的边数的期望。
思路:
对于期望DP。很容易想到状态E[i]表示目前在i这个点。逃出迷宫需要走的边数的期望。然后也可以写出状态转移方程
E[i]=ki*E[1]+0*ei+(1-ei-ki)*Σ(E[j]+1)/eds[i].
j为i所连的点。eds[i]为i的边数。但是发现这个方程完全就不可解。因为方程有环。但是数据量太大高斯消元的话时间复杂明显太高。所以最后还是没做出来。然后就只有看题解咯。还是做题太少啊。这题被我忽略了很重要的一点那就是这是一颗树而不是一张图。而我的方程完全没体现它是树的特点。
如果按照树来写的话,方程应该是这样的。

j为i的儿子。fa为i的父亲。
通过观察。可以设E[i]=A[i]*E[1]+B[i]*E[fa]+C[i]。
然后

然后就上代码了:
#include<algorithm>
#include<iostream>
#include<string.h>
#include<stdio.h>
#include<math.h>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=10010;
const double eps=1e-10;//开始-6wa了。精度要高点才行。
typedef long long ll;
struct node
{
    int v;
    node *next;
} ed[maxn<<1],*head[maxn];
int cnt,eds[maxn];
double A[maxn],B[maxn],C[maxn],ki[maxn],ei[maxn];
void adde(int u,int v)
{
    ed[cnt].v=v;
    ed[cnt].next=head[u];
    head[u]=&ed[cnt++];
}
void dfs(int fa,int u)
{
    double sa,sb,sc,mi;
    sa=sb=sc=0;
    for(node *p=head[u];p!=NULL;p=p->next)
    {
        if(p->v==fa)
            continue;
        dfs(u,p->v);
        sa+=A[p->v];
        sb+=B[p->v];
        sc+=C[p->v];
    }
    mi=(1-ki[u]-ei[u])/eds[u];
    A[u]=(ki[u]+mi*sa)/(1-mi*sb);
    B[u]=mi/(1-mi*sb);
    C[u]=(1+mi*sc-ki[u]-ei[u])/(1-mi*sb);
}
int main()
{
    int t,cas=1,n,i,u,v;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        cnt=0;
        memset(head,0,sizeof head);
        memset(eds,0,sizeof eds);
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            eds[u]++,eds[v]++;
            adde(u,v);
            adde(v,u);
        }
        for(i=1;i<=n;i++)
        {
            scanf("%lf%lf",&ki[i],&ei[i]);
            ki[i]/=100,ei[i]/=100;
        }
        dfs(-1,1);
        printf("Case %d: ",cas++);
        if(fabs(1-A[1])<eps)
            printf("impossible\n");
        else
            printf("%f\n",C[1]/(1-A[1]));
    }
    return 0;
}

抱歉!评论已关闭.