现在的位置: 首页 > 综合 > 正文

POJ 2367 非常基本的拓扑排序题 用GCC可以AC

2018年03月18日 ⁄ 综合 ⁄ 共 2558字 ⁄ 字号 评论关闭

问题描述

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have
one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give
the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about
his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

输入

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council.
According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N.
Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces.
The list of children may be empty. The list (even if it is empty) ends with 0.

(根据红字部分,可知行星依次从1到N来命名,其子行星树,可能为0)

输出

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the
standard output any of them. At least one such sequence always exists.

样例输入

5
0
4 5 1 0
1 0
5 3 0
3 0

样例输出

2 4 5 3 1

问题来源

Ural State University Internal Contest October'2000 Junior Session

完整C代码

#include <stdio.h>
#include <stdlib.h>

typedef struct gNode {
	int vertex;
	int in;
	struct gNode *next;
}gNode;

void CreateAOV( gNode **g, int n )
{
	gNode *p;
	gNode *q;
	int child;
	(*g) = (gNode *)malloc(sizeof(gNode)*n);
	int i;
	for( i=0; i<n; i++ )
		(*g)[i].in = 0;
	for( i=0; i<n; i++ ) {
		(*g)[i].vertex = i+1;			//根据题意依次将顶点赋值为1,2,...,n
		(*g)[i].next = NULL;
		q = *g + i;
		scanf("%d", &child);
		while( 0 != child) {
			p = (gNode *)malloc(sizeof(gNode));
			p->vertex = child;
			p->next = NULL;
			q->next = p;
			q = p;
			(*g)[child-1].in ++;		//由child数值,对相应编号为child-1的顶点入度进行加1
			scanf("%d", &child);
		}
	}
}

void TopSort( gNode *g, int n )
{
	int i;
	int j;
	int k;
	gNode *p;
	
	
	for( i=0; i<n; i++ ) 
		for( j=0; j<n; j++ ) 
			if( 0 == g[j].in ) {
				printf("%d ", g[j].vertex);
				g[j].in = -1;
				p = g[j].next ;
				while( NULL != p ) {
					for( k=0; k<n; k++ )
						if( p->vertex == g[k].vertex ) {
							g[k].in--;
							break;
						}
					p = p->next ;
				}
				break;
			}
			printf("\n");
}

int main()
{
	int n;
	gNode *g;
	scanf("%d", &n);

	CreateAOV( &g, n );
	TopSort( g, n );
	return 0;
}

抱歉!评论已关闭.