现在的位置: 首页 > 综合 > 正文

南洋理工 714 Card Trick

2018年04月04日 ⁄ 综合 ⁄ 共 1747字 ⁄ 字号 评论关闭

Card  Trick

时间限制:1000 ms  |           内存限制:65535 KB
难度:3
描述

The magician shuffles a small pack of cards, holds it face down and performs the following procedure:

  1. The top card is moved to the bottom of the pack. The     new top card is dealt face up onto the table. It is the Ace of Spades.
  2. Two cards are moved one at a time from the top to     the bottom. The next card is dealt face up onto the table. It is the Two     of Spades.
  3. Three cards are moved one at a time…
  4. This goes on until the nth and last card     turns out to be the
    n
    of Spades.

This impressive trick works if the magician knows how to arrange the cards beforehand (and knows how to give a false shuffle). Your program has to determine the initial order of the cards for a given number of cards, 1 ≤ n ≤ 13.

输入
On the first line of the input is a single positive integer k, telling the number of test cases to follow. 1 ≤ k ≤ 10  Each case consists of one line containing the integer n.  1 ≤ n ≤ 13
输出
For each test case, output a line with the correct permutation of the values 1 to n, space separated. The first number showing the top card of the pack, etc…
样例输入

2

4

5

样例输出

2 1 4 3

3 1 4 5 2

 

*注:本题是对牌进行移动操作,这一题只要对题意理解,解题应该不是太难。

  输入4 , 有4张牌, 1 2 3 4,

第一次移牌 移动1次  2 3 4 1, 将最上面的牌取出 ,剩下的牌 3 4 1         (抽出的牌  2)

第二次移牌 移动2次  1 3 4   , 将最上面的牌取出, 剩下的牌 3 4              (抽出的牌  2  1)

第三次移牌 移动3次牌 4 3   , 将最上面的取出,     剩下的牌 3                 (抽出的牌 2 1 4 )

将最后一张牌取出         (抽出的牌 2 1 4 3)

将      2 1 4 3 编号为

          1 2 3 4

这样 1——>2     2----->1   3-------->4      4-------->3

输出 2 1 4 3

下面我的代码用到队列

#include <iostream>
#include <queue>
using namespace std;

int f[15];
int main()
{
	int num, i, flag, count;
	cin>>count;
	while (count--)
	{
	   cin>>num;
       queue <int>q1;  //队列1
	   queue <int>q2;  //队列2
	   for (i=1; i<=num; i++) //将数字从小到大排列
		   q1.push(i);  
	   for (i=1; i<num; i++)//进行1~(num-1)次的移牌操作
	   {
		   flag = i;
		   while (flag--)   
		   {
			   q1.push(q1.front());
			   q1.pop();
		   }
		   q2.push(q1.front()); //将最上面的数放到队列2
		   q1.pop();
	   }
	   q2.push(q1.front());
	   i = 1;
	   while (!q2.empty())
	   {
		   f[q2.front()] = i; //将牌排序
		   q2.pop();
		   i++;
	   }
	   for (i=1; i<=num; i++) //输出
	   {
		   if (i==1)
			   cout<<f[i];
		   else
			   cout<<" "<<f[i];
	   }
	   cout<<endl;
	}
	return 0;
}

 

 

【上篇】
【下篇】

抱歉!评论已关闭.