现在的位置: 首页 > 综合 > 正文

【UVa】 100_3n+1

2018年04月08日 ⁄ 综合 ⁄ 共 3092字 ⁄ 字号 评论关闭
文章目录

100 - The 3n+1 problem

C0 - 编程训练 UVa

Time limit:3.000 seconds

Background

Problems in Computer Science are often classified as belonging to a certain class of problem(e.g.. NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classfication is not known for all possible inputs.

The Problem

Consider the following algorithm:

  1. input n
  2. print n
  3. if n=1 then STOP
  4. if n is odd then n=3n+1
  5. else n=n/2
  6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate(when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that
0<n<1,000,000(and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed(including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no operation overflow a 32-bit integer.

The Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of
output for each line of input. The integers i and j must appear in the output in the same order in which order in which they appeared in the input and should be followed by the maximum cycle length(on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

Solution

My Solution

//*
#define _CRT_SECURE_NO_WARNINGS
#include<stdio.h>

int main()
{
    long ip1, ip2, count=0,max=0;
    while (scanf("%ld %ld", &ip1, &ip2))
    {
        //printf("%ld %ld",ip1,ip2);
        if (ip1 < 1 || ip2<1)
        {
            printf("what you input must be greater than 0!\n");
            continue;
        }
        if (ip1 > ip2)
        {
            long tmp = 0;
            tmp = ip1;
            ip1 = ip2;
            ip2 = tmp;
        }
        for (long i = ip1; i <= ip2; i++)
        {
            //printf("i====%ld\n", i);
            long j = i;
            while (j!=1)
            {
            //    printf("j===%ld", j);
                if (j % 2 == 1)
                //Optimized: if(j&1)
                {
                    j = 3 * j + 1;
                }
                else
                {
                    j /= 2;
                    //Optimized: j>>1;
                    j >> 1;
                }
                count++;
            }
            if (j == 1)
            {
                count++;
            }
            if (count > max)
            {
                max = count;
            }
            count = 0;
        }
        printf("%ld %ld %ld\n", ip1, ip2, max);
        max = 0;
    }
}

//*/

Master:

//*
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
#define SIZE 1000001

static unsigned short table[SIZE];

unsigned short calcCycleLength(register unsigned long n)
{
    if (n < SIZE && table[n])
        return table[n];
    if (n & 1){ 
        if (n < SIZE) {
            //?????????????
            table[n] = 2 + calcCycleLength((3 * n + 1) >> 1); 
            return table[n];
        }
        else
            return 2 + calcCycleLength((3 * n + 1) >> 1);

    }
    else {
        if (n < SIZE) {
            table[n] = 1 + calcCycleLength(n >> 1);
            return table[n];
        }
        else
            return 1 + calcCycleLength(n >> 1);
    }
}

int main()
{
    unsigned long i, fstIn, sndIn;
    short out = 0, temp;

    table[1] = 1;

    while (scanf("%lu %lu", &fstIn, &sndIn) != EOF)
    {
        if (fstIn > sndIn) {
            for (i = sndIn; i <= fstIn; ++i)
            {
                temp = calcCycleLength(i);
                if (temp > out)
                    out = temp;
            }
        }
        else {
            for (i = fstIn; i <= sndIn; ++i)
            {
                temp = calcCycleLength(i);
                if (temp > out)
                    out = temp;
            }
        }
        printf("%lu %lu %hd \n", fstIn, sndIn, out);
        out = 0;
    }
    return 0;
}
//*/

Question

  在大牛的解决方案中,有一处还是不太明白,当n为奇数时为什么要那样操作呢????

抱歉!评论已关闭.