现在的位置: 首页 > 综合 > 正文

POJ_3006

2018年04月13日 ⁄ 综合 ⁄ 共 2308字 ⁄ 字号 评论关闭

一.题目

Dirichlet's Theorem on Arithmetic Progressions
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 15988
Accepted: 8029

Description

If a and d are relatively prime positive integers, the arithmetic sequence beginning with a and increasing by d, i.e., aa + da + 2da +
3da + 4d, ..., contains infinitely many prime numbers. This fact is known as Dirichlet's Theorem on Arithmetic Progressions, which had been conjectured by Johann Carl Friedrich Gauss (1777 - 1855) and was proved by Johann Peter
Gustav Lejeune Dirichlet (1805 - 1859) in 1837.

For example, the arithmetic sequence beginning with 2 and increasing by 3, i.e.,

2, 5, 8, 11, 14, 17, 20, 23, 26, 29, 32, 35, 38, 41, 44, 47, 50, 53, 56, 59, 62, 65, 68, 71, 74, 77, 80, 83, 86, 89, 92, 95, 98, ... ,

contains infinitely many prime numbers

2, 5, 11, 17, 23, 29, 41, 47, 53, 59, 71, 83, 89, ... .

Your mission, should you decide to accept it, is to write a program to find the nth prime number in this arithmetic sequence for given positive integers ad, and n.

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers ad, and n separated by a space. a and d are relatively prime. You may assume a <=
9307, d <= 346, andn <= 210.

The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of as many lines as the number of the input datasets. Each line should contain a single integer and should never contain extra characters.

The output integer corresponding to a dataset adn should be the nth prime number among those contained in the arithmetic sequence beginning with a and increasing by d.

FYI, it is known that the result is always less than 106 (one million) under this input condition.

Sample Input

367 186 151
179 10 203
271 37 39
103 230 1
27 104 185
253 50 85
1 1 1
9075 337 210
307 24 79
331 221 177
259 170 40
269 58 102
0 0 0

Sample Output

92809
6709
12037
103
93523
14503
2
899429
5107
412717
22699
25673

Source



二.解题技巧

    这道题没有什么技巧,就是按照要求计算就可以了。只不过在判断一个数是否为质数的时候,要考虑输入有1的情况。



三.实现代码

#include <iostream>
#include <math.h>

using namespace std;

bool IsPrime(int Value)
{
    if (Value == 1)
    {
        return false;
    }
    if ((Value == 2) || (Value == 3))
    {
        return true;
    }

    if (0 == (Value % 2))
    {
        return false;
    }

    for (int Index = 3; Index <= sqrt((double(Value))); Index = Index + 2)
    {
        if (0 == (Value % Index))
        {
            return false;
        }
    }
    return true;
}


void GetPrimer(int a, int d, int n)
{
    int Index = 0;
    while(true)
    {
        if (IsPrime(a))
        {
            Index++;
        }
        if (Index == n)
        {
            break;
        }

        a += d;

    }
    cout << a << endl;
}




int main()
{
    int a = 0, d = 0, n = 0;

    while(true)
    {
        cin >> a;
        cin >> d;
        cin >> n;

        if ((a == 0) && (d == 0) && (n == 0))
        {
            break;
        }

        GetPrimer(a, d, n);
    }

    return 0;
}


四.体会

    普通的一道题。





版权所有,欢迎转载,转载请注明出处,谢谢微笑

【上篇】
【下篇】

抱歉!评论已关闭.