现在的位置: 首页 > 综合 > 正文

poj3321 Apple Tree

2018年04月23日 ⁄ 综合 ⁄ 共 2647字 ⁄ 字号 评论关闭
Apple Tree
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13203   Accepted: 3867

Description

There is an apple tree outside of kaka's house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won't grow on the same fork. kaka wants to know how many apples are
there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?


Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

带时间戳的树状数组,深搜一遍把每个节点的第一次访问时间和第二次访问时间标出来,然后用这2*n个点构造树状数组,每次更新的时候只更新这个节点的头尾两个时间点,然后这两个时间点之间的数据之和除以2就是查询的答案。

1.树状数组的起始为1

2.这题貌似卡stl……orz……手动建树才不会tle

代码

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

typedef struct
{
    int next,last,num;
}Tree;

int begin[100005];
int end[100005];
int up,p;
int in[200005];
int n;
int vis[100005];
Tree list[100005];
Tree a[400005];

void Build(int x,int y)
{
    if (list[x].next==-1)
    {
        list[x].next=p;
        list[x].last=p;
        a[p].next=-1;
        a[p].num=y;
        p++;
        return;
    }
    int tmp=list[x].last;
    a[tmp].next=p;
    a[p].next=-1;
    a[p].num=y;
    list[x].last=p;
    p++;
}

int lowbit(int t)
{
    return t&(-t);
}

int Query(int t)
{
    int sum=0;
    while(t>0)
    {
        sum+=in[t];
        t-=lowbit(t);
    }
    return sum;
}

void Add(int t,int val)
{
    while(t<=n*2)
    {
        in[t]+=val;
        t+=lowbit(t);
    }
}

void DFS(int k,int t)
{
    int i,j;
    begin[t]=up++;
    for (i=list[t].next;i!=-1;i=a[i].next)
    {
        int tmp=a[i].num;
        if (tmp==k) continue;
        DFS(t,tmp);
    }
    end[t]=up++;
}

int main()
{
    int i,j,x,y,m;
    char str[5];
    while(scanf("%d",&n)!=EOF)
    {
        memset(in,0,sizeof(in));
        for (i=1;i<=n;i++)
        {
            list[i].next=-1;
            vis[i]=1;
        }
        p=0;
        for (i=0;i<n-1;i++)
        {
            scanf("%d%d",&x,&y);
            Build(x,y);
            Build(y,x);
        }
        up=1;
        DFS(0,1);
        in[0]=0;
        for (i=1;i<=2*n;i++)
        {
            Add(i,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%d",str,&x);
            if (str[0]=='Q') printf("%d\n",(Query(end[x])-Query(begin[x]-1))/2);
            else if (vis[x]==0)
            {
                Add(begin[x],1);
                Add(end[x],1);
                vis[x]=1;
            }
            else
            {
                Add(begin[x],-1);
                Add(end[x],-1);
                vis[x]=0;
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.