现在的位置: 首页 > 综合 > 正文

621 – Secret Research

2018年04月23日 ⁄ 综合 ⁄ 共 1505字 ⁄ 字号 评论关闭

  Secret Research 

At a certain laboratory results of secret research are thoroughly encrypted. A result of a single experiment is stored as an information of its completion:

`positive result', `negative result', `experiment failed' or `experiment not completed'

The encrypted result constitutes a string of digits S, which may take one of the following forms:


$\bullet$
positive result 		 S = 1 or S = 4 or S = 78 
$\bullet$
negative result 		 S = S35 
$\bullet$
experiment failed 		 S = 9S4 
$\bullet$
experiment not completed 		 S = 190S

(A sample result S35 means that if we add digits 35 from the right hand side to a digit sequence then we shall get the digit sequence corresponding to a failed experiment)

You are to write a program which decrypts given sequences of digits.

Input 

A integer n stating the number of encrypted results and then consecutive n lines,
each containing a sequence of digits given as ASCII strings.

Output 

For each analysed sequence of digits the following lines should be sent to output (in separate lines):


		 + 		  for a positive result
		 - 		  for a negative result
		 * 		  for a failed experiment
		 ? 		  for a not completed experiment

In case the analysed string does not determine the experiment result, a first match from the above list should be outputted.

Sample Input 

4
78
7835
19078
944

Sample Output 

+
-
?
*

就是道简单的字符串处理题。。一开始数组开小了。RE了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int t,len;
    cin>>t;
    getchar();
    while(t--)
    {
        char str[10000];
        gets(str);
        len=strlen(str);
        if (strcmp(str,"1")==0 || strcmp(str,"4")==0 || strcmp(str,"78")==0) cout<<"+"<<endl;
        else if (strcmp(str+len-2,"35")==0) cout<<"-"<<endl;
        else if (str[0]=='9' && str[len-1]=='4') cout<<"*"<<endl;
        else if (str[0]=='1' && str[1]=='9' && str[2]=='0') cout<<"?"<<endl;
        else cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.