现在的位置: 首页 > 综合 > 正文

排序/查找 10474 – Where is the Marble?

2018年04月23日 ⁄ 综合 ⁄ 共 2116字 ⁄ 字号 评论关闭

UVa OJ

  Where is the Marble? 

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on
them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum
points wins. Today it's your chance to play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to
write a program, which will help you in your role as Raju.

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the
number of marbles and Q the number of queries Mina would make. The next N lines
would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines
will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q =
0
.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • `x found at y', if the first marble with number x was
    found at position y. Positions are numbered 1, 2,...,N.
  • `x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

给你N个数,从小到大排序之后,有q个询问,查找这个数在哪里

一开始打算用二分的,不过发现直接查找也过了。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 10050
using namespace std;
int marble[MAXN];
int main ()
{
    int t=1,n,q,i,j;
    while(cin>>n>>q)
    {
        if (n==0) break;
        for (i=0; i<n; i++)
            scanf("%d",marble+i);
        sort(marble,marble+n);
        printf("CASE# %d:\n",t);
        t++;
        while(q--)
        {
            int a;
            scanf("%d",&a);
            for (i=0; i<n; i++)
                if (marble[i]>=a) break;
            if (i==n) printf("%d not found\n",a);
            else
            {
                if (marble[i]==a) printf("%d found at %d\n",a,i+1);
                else if (marble[i]>a) printf("%d not found\n",a);
            }
        }
    }
    return 0;
}

抱歉!评论已关闭.