现在的位置: 首页 > 综合 > 正文

POJ–1611–The Suspects【并查集】

2018年04月24日 ⁄ 综合 ⁄ 共 2155字 ⁄ 字号 评论关闭

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

思路:使用并查集,将有关系的同学都互相联系起来,最后找最大父树是0的树或者0的所有子树即可。
代码:
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<math.h>
#include<iostream>
#include<time.h>
using namespace std;
int father[30005],a[30005],c[30005];
int find(int x)
{
    int r=x;
    while(father[r]!=r) r=father[r];
    return r;
}
int un(int x,int y)
{
    if(x<y) father[y]=x;
    else father[x]=y;
}
int main()
{
    int n,m,k,i,j,ans,q;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            return 0;
        ans=0;
        for(i=0;i<n;i++)
            father[i]=i;
        for(i=0;i<m;i++)
        {
            scanf("%d",&k);
            for(j=0;j<k;j++)
            {
                scanf("%d",&a[j]);
                c[j]=find(a[j]);
            }
            for(j=0;j<k;j++)
                for(q=j+1;q<k;q++)
                    if(c[j]!=c[q]) un(c[j],c[q]);
        }
        for(i=0;i<n;i++)
        {
            int p=find(i);
            if(p==0) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

抱歉!评论已关闭.