现在的位置: 首页 > 综合 > 正文

hud1114 完全背包 题解

2018年04月25日 ⁄ 综合 ⁄ 共 3237字 ⁄ 字号 评论关闭

   刚学了背包,今天又看了完全背包,非常兴奋的就去做了一道题,现将题解分享给跟我一样的小菜鸟~

   题意分析:现有一个重量为E的存储罐,要求装满后重量达到F。里面有N种硬币,每种硬币的质量和价值分别为P,W,现求出储存罐装满后,可能的最小价值。

传统背包问题中往往是求解背包装满后的最大价值。这需要我们的逆向思维,由max  转化为 min

注意:题目要求的是在储存罐装满的情况下,故需要关注一下初始化问题

有两个重要数组:

dp[i] :存储罐的容量为I时,所装的硬币容量是否也为i(你最多能装多少是由w[i]决定的)

初始化 为零

ser[i] :重量为i时的价值

ser[0]=0,其余初始化为正无穷大

状态转移方程

dp[ j ]=max(dp[j],dp[j-w[i]]+w[i]);对重量的监控

ser[ j ] = min(ser[j],ser[j-w[i]]+P[i])//对价值的监控

题目如下:

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10078    Accepted Submission(s): 5078


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes
all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to
be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

 


Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights
are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are
exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 


Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight
cannot be reached exactly, print a line "This is impossible.". 
 


Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 


Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

现给出AC代码

 

#include <iostream>
#include<string.h>
#include<cstdio>
using namespace std;
const int MAX = 10000+10;
const int index = 500 + 20;
int P[index];
int W[index];
int dp[MAX];
int res[MAX];
int T,E,F,N;
int main()
{
    scanf("%d",&T);
    int i,j;
    while(T--)
    {
        //求出最大的重量(符合要求的重量或是规定的重量)
        memset(dp,0,sizeof(dp));
        memset(res,0x3f,sizeof(res));//赋值无穷大
        res[0]=0;                //当储存罐里的钱是0的时候,最小价值也为0
        scanf("%d%d",&E,&F);
        int ans = F-E;
        scanf("%d",&N);
        for(int i = 1; i <= N; i++)
        {
            scanf("%d%d",&P[i],&W[i]);
        }
        for(i = 1; i <= N; i++)
        {
            for(j = W[i]; j <= ans; j++)
            {
                dp[j] = max(dp[j],dp[j-W[i]] + W[i]);
                res[j]=min(res[j],res[j-W[i]]+P[i]);
            }
        }
        if(dp[ans] == ans)
        {
           printf("The minimum amount of money in the piggy-bank is %d.\n",res[ans]);
        }
        else
        {
            cout << "This is impossible." << endl;
        }
    }
    return 0;
}

抱歉!评论已关闭.