现在的位置: 首页 > 综合 > 正文

【DP】 poj3254 Corn Fields

2018年04月25日 ⁄ 综合 ⁄ 共 1895字 ⁄ 字号 评论关闭
Corn Fields

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares
are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice
as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways
he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

题解:状态压缩DP,dp[i][j]表示第i行放置东西的状态为j的方法数, dp[i][j]=sum(dp[i-1][k]) (k状态和j状态不冲突)

//状态压缩DP
//dp[i][j]表示第i行放置东西的状态为j的方法数
//dp[i][j]=sum(dp[i-1][k]) (k状态和j状态不冲突)
#include<cstdio>
#include<cstring>
using namespace std;
#define mod 100000000
int dp[12][1<<12];
int begin[12];
bool checkA(int x)//判断是否存在相邻的1
{
    return !(x&(x>>1));
}
bool checkB(int a,int b)//判断两个数字是否存在同一位置有1的情况
{
    return !(a&b);
}
int main()
{
    int n,m,t;
    for(; ~scanf("%d%d",&n,&m);)
    {
        memset(dp,0,sizeof(dp));
        memset(begin,0,sizeof(begin));
        for(int i=0; i<n; ++i)
            for(int j=0; j<m; ++j)
            {
                scanf("%d",&t);
                if(t) begin[i]=begin[i]|(1<<j);
            }
        for(int i=0; i<(1<<m); ++i)
            if((begin[0]|i)==begin[0]&&checkA(i))
                dp[0][i]=1;
        for(int i=1; i<n; ++i)
            for(int j=0; j<(1<<m); ++j)
                if(((begin[i]|j)==begin[i])&&checkA(j))
                    for(int k=0;k<(1<<m);++k)
                       if(checkB(j,k))
                           dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
        int ans=0;
        for(int i=0;i<(1<<m);++i)
            ans=(ans+dp[n-1][i])%mod;
        printf("%d\n",ans);
    }
    return 0;
}

来源:http://blog.csdn.net/ACM_Ted

抱歉!评论已关闭.