现在的位置: 首页 > 综合 > 正文

hdu 2279 File Search Tool(java正则表达式使用)

2018年04月25日 ⁄ 综合 ⁄ 共 1652字 ⁄ 字号 评论关闭

牛人博客

http://blog.pureisle.net/archives/635.html

Problem Description
WisKey downloaded much software in winter vacation, and the disk was in a state of confusion. He wastes many times to find the file everyday. So he wants a tool to help him do this work.
The file name consists of lowercase letters.
The name pattern is a string of lowercases, '?'s and '*'s. In a pattern, a '?' matches any single lowercase, and a '*' matches none or more lowercases.
Let’s do this~

 

Input
The first line of input contains two integers N (0 < N <= 10000) and M (0 < M <=100), representing the number of file names and the number of word patterns.
Each of the following N lines contains a file name. After those, each of the last M lines contains a name pattern.
You can assume that the length of patterns will not exceed 6, and the length of file names will not exceed 20.
There are multiple cases in the data file, process to end of file.

 

Output
For each pattern, print a line contains the number of matched file names.
If there is no file name that can match the pattern, print "Not match".

 

Sample Input
4 5 this the an is t* ?h*s ??e* *s e
 

Sample Output
2 1 1 2 Not match
 
import java.util.Scanner;
import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Main {
	public static void main(String[] args) {
		Scanner scanner=new Scanner(System.in);
		while(scanner.hasNext())
		{
		   int n=scanner.nextInt();
		   int m=scanner.nextInt();
		   String string[]=new String[n+1];
		   for(int i=0;i<n;i++)
		   {
			   string[i]=scanner.next();
		   }
		   for(int i=0;i<m;i++)
		   {
			   String string2=scanner.next();
			   String ss="^";
			   string2=string2.replace("?", ".");
			   string2=string2.replace("*", ".*");//.*表示0个或多个字母,因为“.”就表示一个字符
			   ss+=string2;
			   ss+="$";
			   int count=0;
			   Pattern pattern=Pattern.compile(ss);
			   for(int j=0;j<n;j++)
			   {
				   Matcher matcher=pattern.matcher(string[j]);
				   if(matcher.find())count++;
			   }
			   if(count==0)System.out.println("Not match");
			   else System.out.println(count);
		   }
		}
	}
}

抱歉!评论已关闭.