现在的位置: 首页 > 综合 > 正文

hdu 4300 Clairewd’s message(字符串,可以用kmp)

2018年04月26日 ⁄ 综合 ⁄ 共 2208字 ⁄ 字号 评论关闭

本意是让用kmp,不过不用kmp也ac
刚开始少判断条件wrong,详见代码

 

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another
one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action,
she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering
the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the
text is complete.
Hint

Range of test data:
T<= 100 ;
n<= 100000;

 

Output
For each test case, output one line contains the shorest possible complete text.

 

Sample Input
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde

 

Sample Output
abcdabcd qwertabcde

代码:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char b[27],a[27];
    char char1[27],char2[100001];
    int n,mid;
    scanf("%d",&n);
    while(n--)
    {
        scanf("%s",char1);
        for(int i=0;i<26;i++)
        {
            b[char1[i]-'a']=(char)(i+97);
        }
         for(int i=0;i<26;i++)
        {
            a[i]=char1[i];
        }
        scanf("%s",char2);
        int lenght=strlen(char2);
//没有判断lenght,分别为奇数和偶数的情况
        if(lenght%2==0)
        mid=strlen(char2)/2;
        else
        mid=strlen(char2)/2+1;

        int k,flag;
        for(;;)
        {
                k=0;flag=0;
                int midd=mid;
                while(midd<lenght)
                {
                    if(char2[k]!=a[char2[midd]-'a'])
                    {
                        flag=1;break;
                    }
                    else
                    {
                        k++;midd++;
                    }
                }
                if(flag==0)
                {
                    break;
                }
                else
                {
                    mid++;
                }
        }
        if(flag==0)
        {
            for(int i=0;i<mid;i++)
            {
                printf("%c",char2[i]);
            }
            for(int i=0;i<mid;i++)
            {
                printf("%c",b[char2[i]-'a']);
            }
            printf("\n");
        }
        else
        {
            printf("%s",char2);
            for(int i=0;i<lenght;i++)
            {
                printf("%c",b[char2[i]-'a']);
            }
            printf("\n");
        }

    }
    return 0;
}

 

抱歉!评论已关闭.