现在的位置: 首页 > 综合 > 正文

hdu 1009 FatMouse’ Trade(贪心)

2018年04月26日 ⁄ 综合 ⁄ 共 1547字 ⁄ 字号 评论关闭

struct数组用错,而且这个题不用考虑分母为0,还不报错,奇了怪了!!!

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct point
{
    double x,y;
    double bl;
}points[1001];
int cp(const void *a,const void *b)
{
    struct point *c=(point *)a;
    struct point *d=(point *)b;
    if(c->bl<=d->bl) return 1;
    else return -1;//这儿是-1而不是0
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m))
    {
        if(m==-1&&n==-1) break;
        for(int i=0;i<m;i++)
        {
            scanf("%lf %lf",&points[i].x,&points[i].y);
            points[i].bl=points[i].x/points[i].y;
        }
        qsort(points,m,sizeof(points[0]),cp);
        double sum=0.0;
        for(int j=0;j<m;j++)
        {
            if(n>=points[j].y)
            {
                sum+=points[j].x;
                n-=points[j].y;
            }
            else
            {
                sum+=n*points[j].x/points[j].y;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }
    return 0;
}

 

抱歉!评论已关闭.