现在的位置: 首页 > 综合 > 正文

hdu 2680 Choose the best route(注意有向图的处理)

2018年04月26日 ⁄ 综合 ⁄ 共 2198字 ⁄ 字号 评论关闭

注意该题的处理方式,把终点当做原点,用一个数组去标记原来的起点,但是注意这是有向图,对于map[][]必须是有向,因为终点和起点换了位置,所以map[][]跟输入恰好相反

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)     Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 920     Accepted Submission(s): 241

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so
that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases.
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5

1 2 2

1 5 3

1 3 4

2 4 7

2 5 6

2 3 5

3 5 1

4 5 1

2

2 3

4 3 4

1 2 3

1 3 4

2 3 2

1

1

Sample Output

1

-1

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
#define data 100000000
int n,m,s,map[1011][1011],vis[1011],dis[1011],arr[1011];
int main()
{
    int i,j,p,q,t,x,k;
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        memset(arr,0,sizeof(arr));
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                map[i][j]=data;
            }
        }
        for(i=1;i<=n;i++)
        {
            if(i==s) dis[i]=0;
            else dis[i]=data;
        }
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&p,&q,&t);
            if(map[q][p]>t)//注意是有向图,保存时从后往前保存,输入p,q,则保存成map[q][p]    
            map[q][p]=t;
        }
        scanf("%d",&x);
        for(j=0;j<x;j++)
        {
            scanf("%d",&k);
            arr[k]=1;
        }
        for(i=1;i<=n;i++)
        {
            int y,M=data;
            for(j=1;j<=n;j++)
            {
                if(!vis[j]&&dis[j]<M)
                {
                    M=dis[j];y=j;
                }
            }
            vis[y]=1;
            if(M==data) break;
            for(j=1;j<=n;j++)
            {
                dis[j]=(dis[j]>dis[y]+map[y][j]?dis[y]+map[y][j]:dis[j]);
            }
        }
        int min=data;
        for(i=1;i<=n;i++)
        {
            if(arr[i]&&dis[i]<min)
            min=dis[i];
        }
        if(min<data)
        printf("%d\n",min);
        else
        printf("-1\n");
    }
    return 0;
}

 

抱歉!评论已关闭.