现在的位置: 首页 > 综合 > 正文

UVA 10474 Where is the Marble?

2018年04月28日 ⁄ 综合 ⁄ 共 2577字 ⁄ 字号 评论关闭

Description

Download as PDF

Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the
first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it's your chance to
play as Raju. Being the smart kid, you'd be taking the favor of a computer. But don't underestimate Meena, she had written a program to keep track how much time you're taking to give all the answers. So now you have to write a program, which will help you
in your role as Raju.

Input 

There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the
number of queries Mina would make. The next N lines would contain the numbers written on the N marbles.
These marble numbers will not come in any particular order. Following Q lines will have Q queries.
Be assured, none of the input numbers are greater than 10000 and none of them are negative.

Input is terminated by a test case where N = 0 and Q = 0.

Output 

For each test case output the serial number of the case.

For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below:

  • `x found at y', if the first marble with number x was
    found at position y. Positions are numbered 1, 2,..., N.
  • `x not found', if the marble with number x is not present.

Look at the output for sample input for details.

Sample Input 

4 1
2
3
5
1
5
5 2
1
3
3
3
1
2
3
0 0

Sample Output 

CASE# 1:
5 found at 4
CASE# 2:
2 not found
3 found at 3

解题思路:

这道题很水的说,,,但是我交了4次才AC,不就是一个sort后,在新数组上找元素,然后输出位置。。。

代码:

# include<cstdio>
# include<iostream>
# include<algorithm>

using namespace std;

int n, m;
int a[10005], b[10005];

int main(void)
{
    int icase = 1;
    while (scanf("%d%d", &n, &m) != EOF && n && m)
    {
    for (int i = 0; i < n; i++)
        scanf("%d", &a[i]);
    for (int i = 0; i < m; i++)
        scanf("%d", &b[i]);
    sort(a, a + n);
    printf("CASE# %d:\n", icase++);
    for (int i = 0; i < m ; i++)
    {
        int j;
        for (j = 0; j < n; j++)
        {
        if (b[i] == a[j])
        {
            printf("%d found at %d\n", b[i], j + 1);
            break;
        }
        }
        if ( j == n )
        printf("%d not found\n", b[i]);
    }
    }
    return 0;
}

第二种方法是使用 sort+lower_bound结合来完成的。。。有关lower_bound函数的使用,在先前的blog里已经做过详细的介绍了,大家可以翻翻~

int p = lower_bound(a,a+n,x)-a  ,他说的是返回第一个大于或者等于x的元素的下标....

代码:

# include<cstdio>
# include<iostream>
# include<algorithm>


using namespace std;

const int maxn = 10000;

int a[maxn];

int main(void)
{
    int n,q;
    int icase = 1;
    while ( cin>>n>>q )
    {
        if ( n==0&&q==0 )
            break;

        for ( int i = 0;i < n;i++ )
        {
            cin>>a[i];
        }
        printf("CASE# %d:\n",icase++);
        sort(a,a+n);

        while ( q-- )
        {
            int x;
            cin>>x;
            int p = lower_bound(a,a+n,x)-a;
            if ( a[p]==x )
            {
                printf("%d found at %d\n",x,p+1);
            }
            else
            {
                printf("%d not found\n",x);
            }
        }


    }


    return 0;
}

 

抱歉!评论已关闭.