现在的位置: 首页 > 综合 > 正文

HDU 2052

2018年04月29日 ⁄ 综合 ⁄ 共 947字 ⁄ 字号 评论关闭

Picture

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17208    Accepted Submission(s): 8872

Problem Description
Give you the width and height of the rectangle,darw it.
 

Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
 

Output
For each case,you should draw a rectangle with the width and height giving in the input.
after each case, you should a blank line.
 

Sample Input
3 2
 

Sample Output
+---+ | | | | +---+
 

Author
xhd
 

Source

解题思路:

    没什么好说的,都是水题,就是画图了,分三步来画就OK了,第一步,画出第一场,扫一遍加两个+,

    第二步,就是画中间的部分了,有点技巧,a和b互相换下,然后先画|,再画空格。

    第三步,就是和画第一步的思路基本完全一致了,

代码:

# include<cstdio>
# include<iostream>

using namespace std;

int main(void)
{
    int a,b;
    while ( cin>>a>>b )
    {
        cout<<"+";
        for ( int i = 0;i < a;i++ )
        {
            cout<<"-";
        }
        cout<<"+"<<endl;
        for ( int i = 0;i < b;i++ )
        {
            cout<<"|";
            for ( int j = 0;j < a;j++ )
            {
                cout<<" ";
            }
            cout<<"|"<<endl;
        }
        cout<<"+";
        for ( int i = 0;i < a;i++ )
            cout<<"-";
        cout<<"+"<<endl;
        cout<<endl;






    }



    return 0;
}



抱歉!评论已关闭.