现在的位置: 首页 > 综合 > 正文

POJ-2562:Primary Arithmetic

2018年04月29日 ⁄ 综合 ⁄ 共 1447字 ⁄ 字号 评论关闭

时间限制: 
1000ms 
内存限制: 
65536kB
描述
Children are taught to add multi-digit numbers from right-to-left one digit at a time. Many find the "carry" operation - in which a 1 is carried from one digit position to be added to the next - to be a significant challenge. Your job is to count the number
of carry operations for each of a set of addition problems so that educators may assess their difficulty.
输入
Each line of input contains two unsigned integers less than 10 digits. The last line of input contains 0 0.
输出
For each line of input except the last you should compute and print the number of carry operations that would result from adding the two numbers, in the format shown below.
样例输入
123 456
555 555
123 594
0 0
样例输出
No carry operation.
3 carry operations.
1 carry operation.

我的理解是一个硬件模拟类型的题目,用字符模拟加法运算

#include <stdio.h>
#include <string.h>

int main()
{
	/*input*/
	char add1[11];
	char add2[11];
	while( scanf("%s%s",add1,add2)==2 )
	{
		/*end of the input*/
		if(!strcmp(add1,"0") && !strcmp(add2,"0"))
		{	break;	}

		/*calculate*/
		int carryCount = 0;
		int carry = 0;
		int i = strlen(add1)-1;
		int j = strlen(add2)-1;
		while(i!=-1 && j!=-1)
		{
			int temp = add1[i--]-'0'+
				       add2[j--]-'0'+ 
					   carry;
			if( temp>9 )
			{	
				carry = 1;
				carryCount++;
			}
			else
			{	carry =0;	}
		}
		/*add1仍有元素没处理*/
		while(i!=-1 && carry!=0)
		{
			int temp = add1[i--]-'0'+ carry;
			if( temp > 9)
			{
				carry = 1;
				carryCount++;
			}
			else
			{	carry =0;
				break;
			}
		}
		/*add2仍有元素没处理*/
		while(j!=-1 && carry!=0)
		{	
			int temp = add2[j--]-'0'+carry;
			if( temp > 9)
			{
				carry =1;
				carryCount++;
			}
			else
			{
				carry =0;
				break;
			}		
		}

				/*output*/
		if(carryCount ==0)
			printf("No carry operation.\n");
		else if(carryCount ==1)
			printf("%d carry operation.\n",carryCount);
		else
			printf("%d carry operations.\n",carryCount);
	}

	return 0;
}

抱歉!评论已关闭.