现在的位置: 首页 > 综合 > 正文

POJ Ants 1852

2018年05月02日 ⁄ 综合 ⁄ 共 1636字 ⁄ 字号 评论关闭
Ants
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 10575   Accepted: 4682

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know
the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers
giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such
time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

Source

#include<stdio.h>
int maxn[1000010];
int main()
{
	int max(int x,int y);
	int min(int x,int y);
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int l,n,i,minT=0,maxT=0;
		scanf("%d%d",&l,&n);
		for(i=0;i<n;i++)
		scanf("%d",&maxn[i]);
		for(i=0;i<n;i++)
		{
		minT=max(minT,min(maxn[i],l-maxn[i]));
		maxT=max(maxT,max(maxn[i],l-maxn[i]));			
		}
		printf("%d %d\n",minT,maxT);
	 } 
	 return 0;
}
int max(int x,int y)
{
	int z;
	z=x>y?x:y;
	return z;
}
int min(int x,int y)
{
	int z;
	z=x<y?x:y;
	return z;
}
 

水题一发~~开始数组开太小。。最短时间就是走到最近的一端,最长时间就是走到最远的一端。。。

抱歉!评论已关闭.