现在的位置: 首页 > 综合 > 正文

HDU 1219 AC Me

2018年05月02日 ⁄ 综合 ⁄ 共 1378字 ⁄ 字号 评论关闭

AC Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13482    Accepted Submission(s): 5934

Problem Description
Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.
It's really easy, isn't it? So come on and AC ME.
Input
Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end
of file.
Note: the problem has multi-cases, and you may use "while(gets(buf)){...}" to process to the end of file.
Output
For each article, you have to tell how many times each letter appears. The output format is like "X:N".

Output a blank line after each test case. More details in sample output.
Sample Input
hello, this is my first acm contest! work hard for hdu acm.
Sample Output
a:1 b:0 c:2 d:0 e:2 f:1 g:0 h:2 i:3 j:0 k:0 l:2 m:2 n:1 o:2 p:0 q:0 r:1 s:4 t:4 u:0 v:0 w:0 x:0 y:1 z:0 a:2 b:0 c:1 d:2 e:0 f:1 g:0 h:2 i:0 j:0 k:1 l:0 m:1 n:0 o:2 p:0 q:0 r:3 s:0 t:0 u:1 v:0 w:1 x:0 y:0 z:0
/*
\0 ±íʾ½áÊø 
\0 ²»ÊÇ¿Õ¸ñ ,' ' ¿Õ¸ñ 
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define N 100005
char str[N];
int main()
{
	int hash[30];
	int len,i;
//	freopen("text.txt","r",stdin);
	while(gets(str))
	{
		memset(hash,0,sizeof(hash));
		len=strlen(str);
		for(i=0;i<len;i++)
		{
			if(str[i]>='a'&&str[i]<='z')
			{
				hash[str[i]-'a']++;
			}
		}
		
		for(char k='a';k<='z';k++)
		{
			printf("%c:%d\n",k,hash[k-'a']);
		}
		printf("\n");
//		getchar();
	}
	return 0;
} 

抱歉!评论已关闭.