现在的位置: 首页 > 综合 > 正文

杭电1069-Monkey and Banana

2018年05月02日 ⁄ 综合 ⁄ 共 2900字 ⁄ 字号 评论关闭

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5841    Accepted Submission(s): 2966

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with
some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 


Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 


Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case
case: maximum height = height".
 


Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 


Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
一道动态规划题,这里我是按面积排序
AC代码+解释:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<iomanip>
#include<map>
#include<stack>
const int MAX=100;
int DP[MAX];
using namespace std;
typedef struct Rectangle
{
    int l;//length
    int w;//width
    int h;//height
    int area;
};
Rectangle s[MAX];
int maxn(int x,int y)
{
    return x>y?x:y;
}
void sort(int n)//按面积从大到小排序
{
    int i,j,k,Max;
    Rectangle temp;
    for(i=0;i<3*n-1;i++)
    {
        for(j=i+1;j<3*n;j++)
        {
            if(s[i].area<s[j].area)
            {
                temp=s[i];
                s[i]=s[j];
                s[j]=temp;
            }
        }
    }
}
int main()
{
    int n,i,j,Max,p=1;
    int l,w,h;
    while(cin>>n,n)
    {
        j=0;
        for(i=0;i<n;i++)
        {
            cin>>l>>w>>h;
            s[j].l=l;
            s[j].w=w;
            s[j].h=h;
            s[j++].area=l*w;
            s[j].l=h;
            s[j].w=w;
            s[j].h=l;
            s[j++].area=w*h;
            s[j].l=h;
            s[j].w=l;
            s[j].h=w;
            s[j++].area=h*l;
        }
        sort(n);
        DP[0]=s[0].h;
        Max=0;
        for(i=1;i<3*n;i++)
        {
            DP[i]=s[i].h;
            for(j=0;j<i;j++)
            {
                if((s[i].l<s[j].w&&s[i].w<s[j].l)||(s[i].l<s[j].l&&s[i].w<s[j].w))//当上面的底面小于下面的底面
                {
                    DP[i]=maxn(DP[i],DP[j]+s[i].h);//找最大的高度
                }
            }
        }
        Max=-1;
        for(i=0;i<3*n;i++)
        {
            if(Max<DP[i])
            Max=DP[i];
        }
        cout<<"Case "<<p++<<": maximum height = "<<Max<<endl;
    }
    return 0;
}

抱歉!评论已关闭.