现在的位置: 首页 > 综合 > 正文

hdu 1002 A + B Problem II

2018年05月02日 ⁄ 综合 ⁄ 共 2334字 ⁄ 字号 评论关闭

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 209836    Accepted Submission(s): 40373

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using
32-bit integer. You may assume the length of each integer will not exceed 1000.

 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line
between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

/*题解:
    发现杭电和南阳上的大数输出问题不同 ,今天又用java水了一份,java解大数真的很简单。 
    */

JAVA版:
import java.util.*;
import java.math.*;
public class Main {
/**
* @param args
*/
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner in=new Scanner (System.in);
int i,n=in.nextInt();
BigInteger a,b,c;
for(i=1; i<=n; i++){
a=in.nextBigInteger();
b=in.nextBigInteger();
c=a.add(b);
System.out.println("Case "+i+":");
System.out.println(a+" + "+b+" = "+c);
if(i!=n) System.out.println("");              //print("\n");就会PE
}
}
}


C版:

#include<cstdio>

#include<cstring>
int main()
{
    int n,i,j;
    scanf("%d",&n);
    char str1[1010],str2[1010];
    int len1,len2;
    for(j=1; j<=n; j++)
    {
        scanf("%s %s",str1,str2);
        len1=strlen(str1);
        len2=strlen(str2);
       int num1[1010]={0},num2[1010]={0};
        /*memset(num1,0,sizeof(num1));
        memset(num2,0,sizeof(num2));}*/
        //反转并赋值 
        for(i=0; i<len1; i++)
        num1[len1-1-i]=str1[i]-'0';
        for(i=0; i<len2; i++)
        num2[len2-1-i]=str2[i]-'0';
        //令len1为最大 
        if(len1<len2)
        {
            int t=len1;
            len1=len2;
            len2=t;
        }
        for(i=0; i<=len1; i++)
        {
            num1[i] += num2[i];
            if(num1[i]>=10)
            {
                num1[i]-=10;
                num1[i+1]++;
            }
        }
        printf("Case %d:\n",j);

        printf("%s + %s = ",str1,str2);

         //去零

        if(num1[len1]==0)
        {
            for(i=len1-1; i>=0; i--)
            printf("%d",num1[i]);
            printf("\n");
        }
        if(num1[len1]!=0)
        {
            for(i=len1; i>=0; i--)
            printf("%d",num1[i]);
            printf("\n");
        }
        if(j!=n) printf("\n"); 
     }

    return 0;
}
    

抱歉!评论已关闭.