现在的位置: 首页 > 综合 > 正文

HDU 1014 Uniform Generator 【模拟】

2018年05月02日 ⁄ 综合 ⁄ 共 2307字 ⁄ 字号 评论关闭

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18683    Accepted Submission(s): 7329

Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully
can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function.
Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in
column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each
output test set, your program should print exactly one blank line.
 

Sample Input
3 5 15 20 63923 99999
 

Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
 
/*题解:
    根据公式模拟一下就行了。
    其实直接判断是否互质也可以解,因为当二者互质,循环长度一定为Mod 
    英语是硬伤啊--! 
*/
#include<cstdio>
int main()
{
    int step,mod,seed,t;
    while(scanf("%d %d",&step,&mod)!=EOF)
    {
        seed=t=0;
        do
        {
            seed=(seed+step)%mod;
            t++;
        }while(seed!=0);
        if(t==mod)
            printf("%10d%10d    Good Choice\n\n",step,mod);
        else printf("%10d%10d    Bad Choice\n\n",step,mod);
    }
    return 0;
}

抱歉!评论已关闭.