现在的位置: 首页 > 综合 > 正文

HDU 1070 Milk

2018年05月02日 ⁄ 综合 ⁄ 共 2280字 ⁄ 字号 评论关闭

Milk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14376    Accepted Submission(s): 3545

Problem Description
Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

Here are some rules:
1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
2. Ignatius drinks 200mL milk everyday.
3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
4. All the milk in the supermarket is just produced today.

Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
Given some information of milk, your task is to tell Ignatius which milk is the cheapest.

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan)
which is the price of a bottle, V(mL) which is the volume of a bottle.
 

Output
For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
 

Sample Input
2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
 

Sample Output
Mengniu Mengniu
Hint
In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
 /*
题解:水题,刚开始sort排序的cmp函数没加abs,wrong了很多次--!汗~~
*/
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;

struct milk{
    char s[110];
    double p;
    double v;
    int t;
}e[110];

int cmp(milk x,milk y)
{
    if(abs(x.p/x.t*1.0-y.p/y.t*1.0)<0.001) return x.v>y.v;
    else return x.p/x.t<y.p/y.t;
}

int main(){
    char s[110];
    int T,n,i,j,t;
    double p,v;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0,j=0; i<n; i++)
        {
            scanf("%s %lf %lf",s,&p,&v);
            if(v<200)  continue;
            if(v>1000) t=5;
            else t=v/200;
            e[j].t=t;
            strcpy(e[j].s,s);
            e[j].p=p;
            e[j++].v=v;
        }
        sort(e,e+j,cmp);
        printf("%s\n",e[0].s);
    }
    return 0; 
}
            

抱歉!评论已关闭.