现在的位置: 首页 > 综合 > 正文

hdu 1800 Flying to the Mars

2018年05月02日 ⁄ 综合 ⁄ 共 2492字 ⁄ 字号 评论关闭

Flying to the Mars

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11043    Accepted Submission(s): 3553

Problem Description


In the year 8888, the Earth is ruled by the PPF Empire . As the population growing , PPF needs to find more land for the newborns . Finally , PPF decides to attack Kscinow who ruling the Mars . Here the problem comes! How can the soldiers reach the Mars ? PPF
convokes his soldiers and asks for their suggestions . “Rush … ” one soldier answers. “Shut up ! Do I have to remind you that there isn’t any road to the Mars from here!” PPF replies. “Fly !” another answers. PPF smiles :“Clever guy ! Although we haven’t got
wings , I can buy some magic broomsticks from HARRY POTTER to help you .” Now , it’s time to learn to fly on a broomstick ! we assume that one soldier has one level number indicating his degree. The soldier who has a higher level could teach the lower , that
is to say the former’s level > the latter’s . But the lower can’t teach the higher. One soldier can have only one teacher at most , certainly , having no teacher is also legal. Similarly one soldier can have only one student at most while having no student
is also possible. Teacher can teach his student on the same broomstick .Certainly , all the soldier must have practiced on the broomstick before they fly to the Mars! Magic broomstick is expensive !So , can you help PPF to calculate the minimum number of the
broomstick needed .
For example :
There are 5 soldiers (A B C D E)with level numbers : 2 4 5 6 4;
One method :
C could teach B; B could teach A; So , A B C are eligible to study on the same broomstick.
D could teach E;So D E are eligible to study on the same broomstick;
Using this method , we need 2 broomsticks.
Another method:
D could teach A; So A D are eligible to study on the same broomstick.
C could teach B; So B C are eligible to study on the same broomstick.
E with no teacher or student are eligible to study on one broomstick.
Using the method ,we need 3 broomsticks.
……

After checking up all possible method, we found that 2 is the minimum number of broomsticks needed.

 


Input
Input file contains multiple test cases.

In a test case,the first line contains a single positive number N indicating the number of soldiers.(0<=N<=3000)
Next N lines :There is only one nonnegative integer on each line , indicating the level number for each soldier.( less than 30 digits);
 


Output
For each case, output the minimum number of broomsticks on a single line.
 


Sample Input
4 10 20 30 04 5 2 3 4 3 4
 


Sample Output
1 2

/*题解:
题目大意:求有多少个上升串。
先从小到大排序,b[j]作标记用,依次求出有多少上升串(外层循环了几次就有几个上升串)
*/

#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int i,j,n,t,sum,a[3010],b[3010],now;
    while(scanf("%d",&n)!=EOF)
	{
        for(i=0; i<n; i++)
		{
            scanf("%d",&a[i]);
            b[i]=0;
        }
        sort(a,a+n);
        for(i=0,t=0; i<n; i++)
		{
             if(!b[i])
			 {
                for(j=i+1,b[i]=1,now=a[i]; j<n; j++)
				{
                    if(!b[j]&&a[j]>now)
					{
                        b[j]=1;
                        now=a[j];
                    }
                }
              t++;
          }
        }
        printf("%d\n",t);
    }
    return 0;
}
        

抱歉!评论已关闭.