现在的位置: 首页 > 综合 > 正文

POJ 1458 Common Subsequence 【最长公共子序列】

2018年05月02日 ⁄ 综合 ⁄ 共 1370字 ⁄ 字号 评论关闭
Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 39741   Accepted: 15979

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

dp方程:
    s1[i-1]==s2[j-1] dp[i][j]=dp[i-1][j-1]+1
    else    dp[i][j]=max(dp[i-1][j],dp[i][j-1])

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int dp[1010][1010];
int main()
{
    int i,j;
    string s1,s2;
    while(cin>>s1>>s2)
    {
        memset(dp,0,sizeof(dp));
        for(i=1; i<=s1.length(); i++)
        {
            for(j=1; j<=s2.length(); j++)
            {
                if(s1[i-1]==s2[j-1]) dp[i][j]=dp[i-1][j-1]+1;
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        printf("%d\n",dp[s1.length()][s2.length()]);
    }
}

抱歉!评论已关闭.