现在的位置: 首页 > 综合 > 正文

Max Num

2018年05月03日 ⁄ 综合 ⁄ 共 755字 ⁄ 字号 评论关闭

Max Num

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13983    Accepted Submission(s): 8855

Problem Description
There are some students in a class, Can you help teacher find the highest student .
 

Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
 

Output
For each case output the highest height, the height to two decimal plases;
 

Sample Input
2 3 170.00 165.00 180.00 4 165.00 182.00 172.00 160.00
 

Sample Output
180.00 182.00
 
#include<iostream>
#include<iomanip>
#include<vector>
using namespace std;
int main()
{
    int t,n,i;
    double a[110];
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=0; i<n; i++)
            cin>>a[i];
        vector<double>v(a,a+n);
        cout<<fixed<<setprecision(2)<<*max_element(v.begin(),v.end())<<endl;
    }
    return 0;
}
         
    
【上篇】
【下篇】

抱歉!评论已关闭.