现在的位置: 首页 > 综合 > 正文

hdu 1862 EXCEL排序

2018年05月03日 ⁄ 综合 ⁄ 共 1741字 ⁄ 字号 评论关闭

EXCEL排序

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13218    Accepted Submission(s): 5201

Problem Description
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N

行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。
 

Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3

时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
 

Sample Input
3 1 000007 James 85 000010 Amy 90 000001 Zoe 60 4 2 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 98 4 3 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 90 0 0
 

Sample Output
Case 1: 000001 Zoe 60 000007 James 85 000010 Amy 90 Case 2: 000010 Amy 90 000002 James 98 000007 James 85 000001 Zoe 60 Case 3: 000001 Zoe 60 000007 James 85 000002 James 90 000010 Amy 90
 /*题解:
看好题意,  结构体+sort  水过
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct st
{
    int num;
    char name[10];
    int chengji;
}a[100003];
int cmp1(st a,st b)
{
    return a.num<b.num;
}
int cmp2(st a,st b)
{
    if(strcmp(a.name,b.name)!=0)
	{
       return strcmp(a.name,b.name)<0;
    }
    else 
    return  a.num<b.num;
}
int cmp3(st a,st b)
{
    if(a.chengji==b.chengji)
     return a.num<b.num;
     else return a.chengji<b.chengji;
} 
int main()
{
    int N,C,i,t=0;;
    while(scanf("%d %d",&N,&C)&&C)
	{
        memset(a,0,sizeof(a));
        for(i=0; i<N; i++)
        scanf("%d %s %d",&a[i].num,a[i].name,&a[i].chengji);
        if(C==1)
		{
            t++;
            printf("Case %d:\n",t);
            sort(a,a+N,cmp1);
            for(i=0; i<N; i++)
			{
                printf("%06d %s %d\n",a[i].num,a[i].name,a[i].chengji);
            }
        }
            if(C==2)
			{
                    t++;
                    printf("Case %d:\n",t);
                    sort(a,a+N,cmp2);
                    for(i=0; i<N; i++)
					{
                        printf("%06d %s %d\n",a[i].num,a[i].name,a[i].chengji);
                    }
            }
            if(C==3)
			{
                        t++;
                        printf("Case %d:\n",t);
                        sort(a,a+N,cmp3);
                        for(i=0; i<N; i++)
						{
                            printf("%06d %s %d\n",a[i].num,a[i].name,a[i].chengji);
                        }
            }
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.