现在的位置: 首页 > 综合 > 正文

ZOJ2002 Copying Books

2018年12月21日 ⁄ 综合 ⁄ 共 2944字 ⁄ 字号 评论关闭

Copying Books


Time Limit: 2 Seconds     Memory Limit:65536 KB


Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after several months he finished its copy.
One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers
to make copies of these books. Imagine you have m books (numbered 1, 2 ... m) that may have different number of pages (p1, p2 ... pm) and you want to make one copy of each of them. Your task is to divide these books among k scribes, k <= m. Each book can be
assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 0 = b0 < b1 < b2, ... < bk-1 <= bk = m such that i-th scriber gets a sequence of books with numbers between
bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.


Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k, 1 <= k <= m <= 500. At the second line, there are
integers p1, p2, ... pm separated by spaces. All these values are positive and less than 10000000.


Output

For each case, print exactly one line. The line must contain the input succession p1, p2, ... pm divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character ('/') to separate the parts. There
must be exactly one space character between any two successive numbers and between the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.


Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100


Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100


Source: Central Europe 1998



Analysis:

        最大值最小问题 ----->贪心

        N个正整数的k-划分,要求的是划分中最大数的最小值。如有相同最小值,使前面的划分和最小。

        二分判定


Code:

<span style="font-size:14px;">#include <stdio.h>
#include <string.h>
#define max(a,b) a>b ? a : b
int b[510], sg[510];

int main()
{
    int n, m, k, i, sum, t, L , R, mid;
    scanf("%d", &n);
    while (n--) {
        scanf("%d%d", &m, &k);
        L = R = 0;
        for (i = 1; i <= m; i++) {
            scanf("%d", &b[i]);
            L = max(L, b[i]);
            R += b[i];
        }

        while (L <= R) {
            sum = t = 0;
            memset(sg, 0, sizeof(sg));
            mid = (L + R) >> 1;
            for (i = m; i >= 1; i--) {
                if (sum + b[i] <= mid) {
                    sum += b[i];
                } else {
                    sum = b[i];
                    sg[i] = 1;
                    t++;
                    if (t == k) break;
                }
            }
            if (L == R) break;
            if (t == k && i < 0) break;
            else if (t == k && i >= 0) L = mid + 1;
            else if (t < k) R = mid;
        }
//        for(i=1; i<=m; i++) printf("%d   ",sg[i]);
        for (i = 1, t = 0; i <= m; i++)
            if (sg[i]) t++;
//        printf("\n%d\n",t);
        for (i = 1; t < k - 1; i++)
            if (!sg[i]) {
                sg[i] = 1;
                t++;
            }

        for (i = 1; i < m; i++) {
            printf("%d ", b[i]);
            if (sg[i]) printf("/ ");
        }
        printf("%d\n", b[m]);

    }
    return 0;
}

</span>



抱歉!评论已关闭.