现在的位置: 首页 > 综合 > 正文

hdu1024 Max Sum Plus Plus

2018年12月21日 ⁄ 综合 ⁄ 共 1781字 ⁄ 字号 评论关闭

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13233    Accepted Submission(s): 4361


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define
a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im,
jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

 


Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 


Output
Output the maximal summation described above in one line.
 


Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 


Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

分析:

状态dp[i][j]有前j个数,组成i组的和的最大值。决策:
第j个数,是在第包含在第i组里面,还是自己独立成组。
方程 dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
空间复杂度,m未知,n<=1000000, 采用滚动数组(因为dp[i][]阶段由dp[i-1][]阶段推出)
时间复杂度 n^3. n<=1000000.  显然会超时。

优化。
max( dp[i-1][k] ) 就是上一组 0....j-1 的最大值。
我们可以在每次计算dp[i][j]的时候记录下前j个的最大值
用数组保存下来  下次计算的时候可以用,这样时间复杂度为 n^2.

#include <stdio.h>
#include <string.h>
#define INF 0x7fffffff
#define MAXN 1000000
#define max(a,b) ((a)>(b)?(a):(b))
int dp[MAXN + 10];
int upper[MAXN + 10];
int a[MAXN + 10];

int main()
{
    int n, m;
    int i, j, maxx;
    while (~scanf("%d%d", &m, &n)) {
        for (i = 1; i <= n; i++) {
            scanf("%d", &a[i]);
        }
        memset(dp,0,(n+1)*sizeof(dp[0]));
        memset(upper,0,(n+1)*sizeof(upper[0]));
        for (i = 1; i <= m; i++) {
            maxx = -INF;
            for (j = i; j <= n; j++) {
                dp[j] = max(dp[j - 1] + a[j], upper[j - 1] + a[j]);
                upper[j - 1] = maxx;
                maxx = max(maxx, dp[j]);
            }
        }
        printf("%d\n", maxx);
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.