现在的位置: 首页 > 综合 > 正文

hdu 2660 Accepted Necklace (二维01背包)

2018年12月21日 ⁄ 综合 ⁄ 共 1489字 ⁄ 字号 评论关闭

Accepted Necklace

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 25   Accepted Submission(s) : 5

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will
accept.

Input

The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 

Output

For each case, output the highest possible value of the necklace.

Sample Input

1 
2 1 
1 1 
1 1 
3 

Sample Output

1 

分析:

简单背包

f[j][k] 表示一个体积为j,最多能放k个precious stone的背包所能达到的最大价值。

状态转移方程: f[j][k] = max{f[j-a[i].w][k-1]} +a[i].v;


#include <stdio.h>
#include <string.h>
struct node {
    int v,w;

} a[21];
#define INF 0xfffffff
int f[1005][21];
int n, k,w;
void dp() {
    int i,j, p;
    int max;
    memset(f,0,sizeof(f));
    for(i=0; i<n; i++) {
        for(j=w; j>=a[i].w; j--) {
            for(p=1; p<=k; p++) {
                max = f[j][p];
                if(max<f[j-a[i].w][p-1]+a[i].v) max = f[j-a[i].w][p-1]+a[i].v;
                f[j][p] = max;
            }
        }

    }
    max =-INF;
    for(i=0; i<w; i++) if(max<f[i][k]) max = f[i][k];
    printf("%d\n",max);
}
int main() {
    int T,i;
    scanf("%d",&T);
    while(T--) {
        scanf("%d%d",&n,&k);
        for(i=0; i<n; i++) scanf("%d%d",&a[i].v,&a[i].w);
        scanf("%d",&w);
        dp();
    }
    return 0;
}

抱歉!评论已关闭.