现在的位置: 首页 > 综合 > 正文

POJ 2051 Arugs

2018年12月23日 ⁄ 综合 ⁄ 共 2589字 ⁄ 字号 评论关闭
Argus
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8585   Accepted: 3862

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams
run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding
user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 

Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be
returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time,
they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005

Source

题目没看仔细,我还以为题目数据有误。WA了1次。->:)
我用priority_queue 优先队列解决了,我看别人直接模拟也过了 …… :(
#include <cstdio>
#include <queue>
#include <iostream>
using namespace std;


struct node {
    int t;
    int Q_num;
    int Period;
    bool operator <(const node& q) const {
        if(t != q.t)
            return t > q.t;
        else
            return Q_num > q.Q_num;
    }
};
int main() {
    char s[20];
    int x, y;
    int k, i = 0;
    node temp;
    priority_queue <node> q;
    while(scanf("%s",&s)&&s[0] !='#') {
        scanf("%d%d", &x,&y);
        temp.t =y, temp.Q_num = x, temp.Period = y;
        q.push(temp);
        i++;
    }
    scanf("%d",&k);
    while(k--) {
        temp = q.top();
        printf("%d\n",temp.Q_num);
        q.pop();
        temp.t = temp.t + temp.Period;
        q.push(temp);
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.