现在的位置: 首页 > 综合 > 正文

POJ 2418 ,ZOJ 1899 Hardwood Species – from lanshui_Yang

2019年01月07日 ⁄ 综合 ⁄ 共 3055字 ⁄ 字号 评论关闭

Description
Hardwoods are the botanical group of trees that have broad leaves, produce a fruit or nut, and generally go dormant in the winter. 
America's temperate climates produce forests with hundreds of hardwood species -- trees that share certain biological characteristics. Although oak, maple and cherry all are types of hardwood trees, for example, they are different species. Together, all the
hardwood species represent 40 percent of the trees in the United States. 

On the other hand, softwoods, or conifers, from the Latin word meaning "cone-bearing," have needles. Widely available US softwoods include cedar, fir, hemlock, pine, redwood, spruce and cypress. In a home, the softwoods are used primarily as structural lumber
such as 2x4s and 2x6s, with some limited decorative applications. 

Using satellite imaging technology, the Department of Natural Resources has compiled an inventory of every tree standing on a particular day. You are to compute the total fraction of the tree population represented by each species.

Input

Input to your program consists of a list of the species of every tree observed by the satellite; one tree per line. No species name exceeds 30 characters.
There are no more than 10,000 species and no more than 1,000,000 trees.

Output

Print the name of each species represented in the population, in alphabetical order, followed by the percentage of the population it represents, to
4 decimal places.

Sample Input

Red Alder
Ash
Aspen
Basswood
Ash
Beech
Yellow Birch
Ash
Cherry
Cottonwood
Ash
Cypress
Red Elm
Gum
Hackberry
White Oak
Hickory
Pecan
Hard Maple
White Oak
Soft Maple
Red Oak
Red Oak
White Oak
Poplan
Sassafras
Sycamore
Black Walnut
Willow

Sample Output

Ash 13.7931
Aspen 3.4483
Basswood 3.4483
Beech 3.4483
Black Walnut 3.4483
Cherry 3.4483
Cottonwood 3.4483
Cypress 3.4483
Gum 3.4483
Hackberry 3.4483
Hard Maple 3.4483
Hickory 3.4483
Pecan 3.4483
Poplan 3.4483
Red Alder 3.4483
Red Elm 3.4483
Red Oak 6.8966
Sassafras 3.4483
Soft Maple 3.4483
Sycamore 3.4483
White Oak 10.3448
Willow 3.4483
Yellow Birch 3.4483

      题目大意:给你一些字符串,让你统计每个字符串出现的概率。

      解题思路:此题我是用Trie树来写的,用map可能会TLE。输出字符串的时候要求按字典序,于是我就用了dfs。

      Ps:这道题在POJ上是单组数据,但在ZOJ上是多组数据,请大家注意!另外,此题中的字符串中可能会包含除字母外的其他字符,大家小心!

      请看代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#define mem(a , b) memset(a , b , sizeof(a) )
using namespace std ;
const int MAXN = 3e5 + 5 ;
char A[50] ;
int vis[MAXN] ; // 建立标记数组,用于最后输出字符串
int cnt ;  // 给Trie树中每个结点设定编号
int sum ;  // 统计字符串的个数
struct Tnode
{
    int count ; // 统计该结点出现的单词个数
    char f ;  // 记录Trie树中结点所存的字符
    int xu ;  // 记录Trie树中结点的序号
    Tnode * next[256] ; // 数组开大一些,因为可能会包含除字母外的其他字符。
    Tnode()
    {
        count = 0 ;
        f = 0 ;
        xu = 0 ;
        mem(next , 0) ;
    }
} ;
char s[50] ;
void inse(char * str , Tnode * root)
{
    Tnode * p = root ;
    int id ;
    while (*str)
    {
        id = *str - '\0' ;
        if(p -> next[id] == 0)
        {
            p -> next[id] = new Tnode ;
            p -> next[id] -> xu = ++ cnt ;
            p -> next[id] -> f = *str ;
        }
        p = p -> next[id] ;
        ++ str ;
    }
    p -> count ++ ;
}
double ans ;
void print(int deep , Tnode * p) // dfs 按字典序输出字符串 , deep为递归的深度
{
    int i ;
    for(i = 0 ; i < 256; i ++ )
    {
        if(p -> next[i] != NULL)
        {
            int tmp = p -> next[i] -> xu ;
            A[deep] = p -> next[i] -> f ;
            if(p -> next[i] -> count > 0 && !vis[tmp])
            {
                vis[tmp] = 1 ;
                ans = p -> next[i] -> count * 100.0 / sum * 1,0;
                int j ;
                for(j = 0 ; j <= deep ; j ++)
                {
                    printf("%c" , A[j]) ;
                }
                printf(" %.4f\n" ,ans) ;
            }
            print(deep + 1 , p -> next[i]) ;
        }
    }
}
int main()
{
    bool flag = false ;
    while (gets(s))
    {
        if(flag)   // 相邻两组数据间输出一个空行
        printf("\n") ;
        else
        flag = true ;
        cnt = 0 ;
        sum = 0 ;
        Tnode * root = new Tnode ;
        memset(vis , 0 , sizeof(vis)) ;
        inse(s , root) ;
        sum ++ ;
        while (gets(s) && strlen(s))
        {
            inse(s , root) ;
            sum ++ ;
        }
        print(0 , root) ;
    }
    return 0 ;
}


抱歉!评论已关闭.