现在的位置: 首页 > 综合 > 正文

POJ 1300 Door Man – from lanshui_Yang

2019年01月08日 ⁄ 综合 ⁄ 共 3042字 ⁄ 字号 评论关闭

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the
house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 
  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 
  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents
    room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent
    rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors
he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10
题目大意不在敖述,此题是一道典型的求无向图中有无欧拉回路或欧拉通路的问题。首先是建图:以房间为顶点,房间之间的门为边建立无向图。然后就是输入问题,要求大家对字符串的有较好的处理能力,我用的是getchar()。然后请看代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string>
#include<cmath>
#include<cstdlib>
#include<queue>
using namespace std ;
const int MAXN = 105 ;
const int INF = 0x7fffffff ;
int d[MAXN] ; // 建立顶点的度的数组
int main()
{
    string s ;
    int m , n ;
    int sumt , sumj , sumd ;
    while (cin >> s)
    {
        if(s == "START")
        {
            scanf("%d%d" , &m , &n) ;
            getchar() ; // 处理刚才的回车,此处千万不要忘记 !!
            memset(d , 0 , sizeof(d)) ;
            int i ;
            sumd = 0 ; // 统计边的数目,即门的数目
            int pan = 0 ; // 注意这个判断变量的应用,请大家自己体会 !!
            for(i = 0 ; i < n ; i ++)
            {
                sumt = 0 ;
                char t ;
                while (1)
                {
                    t = getchar() ;
                    if(t == '\n')
                    {
                        if(pan)
                        {
                            d[i] ++ ;
                            d[sumt] ++ ;
                            sumd ++ ;
                            pan = 0 ;
                        }
                        break ;
                    }
                    if(t == ' ')
                    {
                        d[i] ++ ;
                        d[sumt] ++ ;
                        sumd ++ ;
                        sumt = 0 ;
                    }
                    else
                    {
                        sumt = sumt * 10 + t - '0' ;
                        pan = 1 ;
                    }
                }
            }
        }
        if(s == "END")
        {
            int j ;
            sumj = 0 ; // 统计奇度顶点的个数
            for(j = 0 ; j < n ; j ++)
            {
                if(d[j] % 2 == 1)
                {
                    sumj ++ ;
                }
            }
            if(sumj > 2 || sumj == 1)
            {
                printf("NO\n") ;
            }
            else if(sumj == 0 && m != 0)
            {
                printf("NO\n") ;
            }
            else if(sumj == 2 && (d[m] % 2 != 1 || d[0] % 2 != 1))
            {
                printf("NO\n") ;
            }
            else if(sumj == 2 && d[m] % 2 == 1 && d[0] % 2 == 1 && m == 0)
            {
                printf("NO\n") ;
            }
            else
            {
                printf("YES %d\n" ,sumd) ;
            }
        }
        if(s == "ENDOFINPUT")
        {
            break ;
        }
    }
    return 0 ;
}

抱歉!评论已关闭.